[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Multiple NICs on Umax S900

I've tried in vain for some time now to get my old dual-proc SuperMac
S900 to work properly with more than the OEM 10 Mb NIC installed. I've
had relatively little difficulty with 'unstable' on this box. It
successfully boots either 2.4 or 2.6 kernels. Networking fails in
various ways when I install a second NIC. Usually, the installed devices
can still be configured, but they just don't respond to any attempts to
communicate over the network. For instance, attempting to request a DHCP
lease fails as if there were no other hosts on the network.

I've tried two different NICs: a 100Mb LinkSys and a gigabit
RealTek-based model. Both exhibitied similar behaviors.

When booted from the 2.4.25-powerpc-smp-pmac kernel, I can get the
gigabit card to be recognized, and can configure the device, but at the
first sign of network activity (pings from another machine, in this
case), the SuperMac essentially locks up, spewing "too much work at
interrupt" down the monitor.

When booted from the 2.6.8-powerpc-smp kernel, I don't even have to have
a second NIC installed to cause problems. I can probe in the r8169
RealTek gigabit driver (which I don't think I *should* be able to do
when the card isn't even installed), which immediately kills the OEM NIC
-- it just won't configure any longer. Attempting to remove the r8169
module freezes up the machine.

I couldn't find any mention of this sort of problem in the archives. Any
ideas? I'd pull the OEM card, but it also happens to include the serial


Reply to: