[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: G5 XServe

On Wed, Sep 08, 2004 at 10:24:21AM +0200, Sven Luther wrote:
> On Tue, Sep 07, 2004 at 10:40:19PM +0100, Colin Watson wrote:
> > The PPC32 2.6.7 kernel doesn't support the XServe G5. Here's a kernel
> > patch that worked for us (also sent upstream):
> > 
> >   http://www.no-name-yet.com/patches/kernel-source-2.6.7.xserve-g5.diff
> What about 2.6.8 ? In particular what about the 2.6.8 debian kernels ? 
> The patch seems small, but from a quick glance, the cpu_setup_power4.S hunks
> may need investigation and testing on non-G5 power4 boxes and older G5 ones.

I simply backported them from the PPC64 kernel. BenH would know more
detail about what they're actually doing. That said, they seem very
straightforward; all they're doing is comparing against the PVR values
for both the PPC970 (in older G5s) and the PPC970FX (in the XServe G5).
I don't see that affecting non-G5s or older G5s.


Colin Watson                                       [cjwatson@debian.org]

Reply to: