[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

[iBook 2.2] Blank screen, no X - kernel issue?

Hello list!

With a fresh Sarge install from d-i RC1 on my iBook 2.2, I cannot get X
to work. Using the plain default kernel 2.6.7-5 gives a blank console.
Adding video=ofonly makes the console work, but startx again blanks the
Some people wrote that the Open Firmware framebuffer driver (aka ofonly)
breaks X, so that's not very surprising. But radeonfb seems to be
broken, too, and I've found nobody experiencing the same behaviour :-(

Using kernel 2.4.26, there's no need to specify boot parameters for
the console, but X still doesn't function...

This is my first try with Linux on Powerpc, and I've no idea. Any
experts around here? Did someone run into the same problem and fixed it?

dmesg's output of the plain 2.6.7 kernel is attached, grabbed with
a remote shell.
Rather than posting all potentially relevant configs and logs, I've put
the dmesg, XF86Config-4 and, if possible, XFree86.logs for the kernels
2.6.7 and 2.4.26 on a website:


Thanks very much,

Reply to: