[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: new oldworld pmac miboot 2.6 floppies, root size should be ok, net_drivers still too big, please test.

On Thu, Aug 19, 2004 at 02:34:48PM +0200, Wouter Hanegraaff wrote:
> Hi,
> On Thu, Aug 19, 2004 at 04:25:43AM -0400, Rick_Thomas wrote:
> > Hi Sven,
> > 
> > Progress, of a sort...
> > 
> > I was really hopeful because when I booted either of the "boot" or
> > "ofonlyboot" floppy, I got the TuxMac icon for a while and the Mac made
> > happy floppy disk reading noises.  However, the noises eventually
> > stopped and a red "X" appeared over the TuxMac. Then nothing.  I had to
> > manually eject the floppy from the drive.
> I'm testing the powerpc-small boot floppies and this occurred when I

Where did you download those from, and when ? 

> tried to boot my powermac 7300 with ofonlyboot.img. However, after
> reformatting with superformat and writing the image again, the disk was
> read successfully and ejected. I inserted root.img, which was loaded,
> but after that nothing happened. I ended up with the tuxmac logo and the
> root disk in the drive. 
> After reading that your mac booted from boot.img, I tried that one
> and with a little more success. After loading the kernel, the system
> switched to text mode and asked for the root floppy. I inserted root.img

Cool, this is progress. Now if you could test the same with the powerpc/floppy
ones that use the 2.6 kernels ?

> and it loaded for a while, but the end result was something along the
> following lines: 
> mount_devfs_fs(): unable to mount devfs, err:-2
> freeing unused kernel memory
> warning, unable to open an initial console
> Kernel panic, no init found

Mmm, not cool. Could you have more of the info ? If you have a digicam, you
could take a picture or something, if you are not able to get the serial log.

Did it work using the bootx method ? 


Sven Luther

Reply to: