[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

2.4.18 (on PM7600) - video fails - uniform grey screen

Good folk,

I decided to take a plunge into more modern times and switch to 2.4.18 from the default 2.2.20. I suspected there might be a glitch or two since the 7600 is an oldworld, so I re-read all my original install notes before starting. The commands i issued went like this:

# apt-get install kernel-image-2.2.20-pmac
     (odd how it's not packaged by the old installer!)
# apt-get install kernel-image-2.4.18-powerpc
A ner kernel image has been installed [ snip ] so please ignore this if you are using such a boot loader. [ snip ]
Do you wish to set up Linux to boot from the hard disk?
# hmount /dev/sda
# hcopy -r /boot/vmlinux-2.4.18-powerpc debian:System\ Folder:Linux\ Kernels:vmlinux-2.4.18-poerpc
     (thank goodness i took detailed notes during my original install)
# humount
# shutdown -r now

Upon selecting the new kernel in BootX, the screen went grey (normal) and stayed that way (not normal) with no cursor visible. I could hear the disk drive chattering away, so I thought "don't panic, maybe 2.4.18 just takes a few moments to set up the video." Several minutes later, I was still looking at a uniform grey screen. On a hunch, I tried (since I normally use kdm)
and the 7600 rebooted. Hmmmm. That's what I would expect if my eyes were closed, sort of a good sign, I suppose. On the second go-round, the video had the same problem. I waited and waited and then typed in
  shutdown -r now
and the machine promptly rebooted. So - linux seems to be working correctly, but it won't share what it's doing with the outside world.

Off to Google I went, in search of solutions. This led to mucking with the BootX video parameters. I've tried
with and without various combinations of cmode and vmode, and all with the same result.

I'm stumped, and am back at using 2.2.20.  Which FAQ did I not find read?

Peter Rooney

Reply to: