[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: 2.4 & 2.6 kernels, should sarge be 2.6 only at least for powerpc ?

On Sat, Jul 03, 2004 at 10:57:00PM +0200, Sven Luther wrote:
> Yeah, in the meantime, i need to release a 2.4.26 kernel as there are
> people clamoring for it, since the 2.4.25 has some security holes whose
> fixes where not backported, and 2.6 is not considered stable by some
> users yet (and if you want to fight it, you are welcome to engage in a
> flamewar with Branden, i certainly won't :).
> The patch from 2.4.26 -benh tree apply cleanly but doesn't build
> (probably because of two conflicting libata patches, but maybe because
> some other bits and pieces), and altough i worked at it some, it is
> still failing with :
> fs/fs.o(.text+0x119cc4): dans la fonction ? syncd ?:
> : undefined reference to `sigmask_lock'
> fs/fs.o(.text+0x119cdc): dans la fonction ? syncd ?:
> : undefined reference to `__recalc_sigpending'
> fs/fs.o(.text+0x119ce0): dans la fonction ? syncd ?:
> : undefined reference to `sigmask_unlock'
> Could you (or someone else) have a look at the stuff ? The patch against
> kernel-source-2.4.26 is at : 

Hmm, this looks like xfs_super.c doesn't pick up xfs_buf.h.  I'll look
at this in more detail tomorrow.

Reply to: