[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Debian on F50...

Thanks for the reply Sven, comments below.
Cheers Rich.

On Tue, 2004-05-25 at 14:45, Sven Luther wrote:
> On Tue, May 25, 2004 at 09:15:21AM +0100, Richard Wale wrote:
> > Howdy,
> > 
> > I've had a Debian running happily on a 7025/F50
> > RS/6000 for a number of years, after follows some
> > steps posted on this mailing list.  Using the rsync
> > sources from source.mvista.com, I've had both 2.4.x
> > and 2.6.x kernels working. 2.6 really made it fly,
> > gnome is now pretty quick to use.
> Notice that the debian 2.4.25 kernel has been tried on both a F50 and a
> B50, presumably the 2.6.6 kernel should also, it has probably never been
> tested though, and there could be problems with the initrd.
> That also means that the debian-installer should work out of the box on
> that hardware.
> > I initially I was copying the kernel to floppy or CD
> > and using the SMS to boot the rootfs on the internal
> > disks; however in recent times I was able to get
> > yaboot to install and work.
> > 
> > Sadly looks like I have to soon give up my desktop
> > (well under-desk) machine and swap it for an intel
> > box.
> BTW, what will happen to the old box ? 
The F50 will be turning from desktop back to server, to be a test
Management Server for a CSM Cluster.

> > Would anyone be interested in me posting my kernel
> > .configs or my XF86Config-4?  I didn't know if any of
> > the ppc maintainers might find them useful?
> It would always be usefull, altough i think that at least for the
> .config we already did the work for it. If you could try out the 2.6.6
> kernel package before you lose access to the box, that would be great.
> That and the debian-installer too.
I downloaded the debian 2.6.6 source and successfully compiled a SMP

I had to change my yaboot config to get the kernel to boot (not a
problem with the debian kernel, I'd had the same issue with kernel's
past 2.6.3 built from the mvista source).  Booting would fail to
mount/find the rootfs.

The solution was in the yaboot.conf :

boot = /dev/sda1
# device=/pci/@fef00000/scsi@c/sd@8
device = disk
partition = 2
timeout = 300
delay = 30
install = /usr/lib/yaboot/yaboot
default = linux

image = /vmlinux
       root = /dev/sda2
                label = Linux2.4

image = /boot/vmlinux-2.6
       root = /dev/sda2
                label = Linux2.6

image = /boot/vmlinux-2.6
       root = 0802
                label = Linux2.6test

The 2.4 kernel will boot fine. "Linux2.6" will fail to find the rootfs. 
"Linux2.6test" works fine.  The "root =" definition was the key.

But yes, you are correct that the stock debian kernel will indeed boot
an F50.  I won't get chance to use the debian installer, but the
original (I guess in my case from potato) worked for me, once I had a
suitable 2.4 kernel to boot from. 2 floppies and a network connection
and everything worked fine back then.

If anyone would like any of the configuration files just email me.  I'll
tar the valuable things up before I put AIX back on it.

> Friendly,
> Sven Luther
Richard Wale <richard_wale@yahoo.co.uk>

Reply to: