[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [PATCH] Albook fan driver


On Fri, Jan 23, 2004 at 05:45:09PM +0100, Marco Giordani wrote:
> On Fri, Jan 23, 2004 at 05:21:43PM +0100, Colin Leroy wrote:
> > the powerbook model perhaps. Try to set "limit_decrease=10 fan_speed=255"
> > to see the maximum...
> Ok. On my Albook 15" 1.25GHz:
> fan_speed=128 returns 2070
> fan_speed=255 returns 2800
> Bye,
> Marco
Mmh, playing around with the module a bit right now, I notice something
strange. Without the module loaded something in the hardware seem to
care about the cooling. In fact, the fan is not running at full speed as
I thought some minutes before. When I load the module without parameters
the fan stops for a short while and then starts to run at full speed
(well at least it sounds much louder than before and:
wolfi@halley:/sys/devices/temperatures $ cat fan_speed 
8695 )
This is with one loop. When I stop this loop, the fan slows down after a
while and finally stops. If I load the module in this stage the fan
starts again and I have the 6700 rpm. 

I took the following table:
fan_speed=param		cat fan_speed
32			3200
64			4880
128			6420
150			6880
200			7860
255			8400

Judging by ear, the maximum fan speed without your module loaded is
around 7000.
So, what drives my fan in absence of your module? The PMU?.



> -- 
>   Marco Giordani <giordani@cs.unibo.it> - GnuPGid 0x229B1BE8/1024
>   Key fingerprint = F1C8 CD45 210D 6C19 A5FD  A864 FA01 3E5C 229B 1BE8

Reply to: