[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Can I Install AND boot a new Kernel on an OldWorld PMac?

Thanks Nathanael!

That fixed it (sorta! read on...)

I tried booting the 2.4.18 kernel using BootX with both the video
options off ("no video driver" and "force video settings") and I
got the expected familiar scrolling text status messages and a
login: prompt.  (Whoopee!) I could log in and do normal text
console stuff.  (Double Whoopee!)

However... It was a 600x400 screen, not the 832x624 screen that
I'm used to.  It's annoying to be confined to a 80x30 character
screen when you're used to 104x39 !  Bummer!

So I tried again leaving the "force video settings" box checked,
and got the same results -- a 600x400 pixels screen.  (8-<)

For completeness, I tried the only remaining combination ("no
video driver" on, and "force video settings" off) and got a black
screen. (8-<) Fortunately, I was able to login remotely using
telnet and reboot gracefully, so no harm done. (8->)

Note: This is *not* an XF86 config problem, because I've set the
default X11 display manager to "none".  I normally want to run
this configuration as a server, not a desktop, so I normally want
a console command-line interface, not a gui interface.  However,
for completeness, I did try to start X-windows (typed "startx")
and it obediently started up the Gnome window manager, but the
screen was all skewed.  I assume that this problem will go away if
I can figure out how to get my console video back to 832x624 mode.

So ... How do I get my 832x624 video mode back?  (And get startx
to work again?)  (8-\)



PS -- For what it's worth, an identical box sitting right next to
it, but running YellowDog Linux instead of Debian, boots the YDL
2.4.22 kernel just fine with both video options set.  And I get a
832x624 screen.  Go figure!  (?-/)

Nathanael Hasbrouck wrote:
> On Thursday 15 January 2004 16:36, somebody named Rick Thomas inscribed this
> message:
> > I tell BootX to load the 2.4.18 kernel, make sure that the "use frame
> > buffer video" and "force video mode" checkboxes are set, click the
>                                    ^^^^^^^^^^^^^^^^^^^^^^^
> I don't think you want the force video set for 2.4 kernels.  It's required for
> 2.2.x, but breaks for 2.4.x IIRC.  And you're right, the machine probably is
> booting fine, you just can't see it.  If you're set to boot into runlevel 2,
> let it go untill the hard disk hasn't done anything for a couple minutes and
> you can probably log in (as root, and type carefully, you don't want any
> typos ;) and type 'shutdown -r now' to reboot the box.  If it doesn't work,
> either 1) I'm wrong, 2) you made a typo, or 3) you might be logged in as a
> normal user, who can't call 'shutdown' from a command line.  :^)

Reply to: