[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: TiBook adventures

X works fine here on my AlBook 1.33GHz 17'' (ATI Radeon 9600)

kernel: 2.6.0-ben1 (AFAIK, no problems with newer 2.6.X)
debian-dist: sid
xserver: xserver-xfree86-dri-trunk (from michel daenzer)
Section "Device"
	Identifier	"AlBook Internal Video"
	Driver		"radeon"
	Option		"UseFBDev"


On Fri, Jan 02, 2004 at 04:26:59PM +0100, mammique wrote:
> Hi all,
> i'm trying to make the new PowerBook G4 to work under debian unstable
> since few month with no succes, most of problems comes from the radeon
> 9600. I tried benh kernels :
> 2.4.23-ben1
> 2.4.23-pre5
> 2.6.0
> 2.6.0-test11
> 2.6.1-rc1
> first i thought xfree didn't start because of radeonfb not working with
> 2.4.23-pre5, i must use offb or ofonly (xfree don't want them), then i
> tried 2.6.0-test11 wich accepts radeonfb but with blank screen, no
> succes with xfree. In fact Xfree didn't know radeon 9600 so i installed
> xfree86 4.3.99 from :
> ftp://ftp.ppcnux.de/pub/Mirrors/ftp.debian.de/xfree86/dists/sid/binary-powerpc/ (if somebody knows a better version i'm aware, this one isn't very good, X11 forwarding don't work and whiteglass cursor only on qt apps, i don't care about whiteglass but it's strange)
> then it worked with 2.6.0-test11 (blind during boot because of radeonfb
> but xfree launches), but then each time i try to launch a video app the
> kernel freezes, i used mplayer (mpeg work but not other formats) or
> xine. It don't seems to be xfree fault because if i launch from another
> machine with no X (mplayer -vo null) the machines hangs, no ping, i have
> to hard reboot. Later i tried 2.6.0-test11 and 2.6.1-rc1 wich xfree
> don't work uppon (awfull parasites, imposible to read anything on the
> screen) - Each time with about "same" .config - My last try was
> 2.4.23-ben1 wich is the only able to display corectly radeonfb at boot,
> woow :-) ! But Xfree display is buggy (less than 2.6.0-test11 and
> 2.6.1-rc1) and each time i launch a gnome-session from gdm kernel hangs
> (no ping). Does anybody experienced/solved those problems ? A working
> .config file or a better Xfree86 release ? A idea ?
> Thanks !
> PS: config files -> http://industrie.dyndns.org/soft/debian/TiBook
> -- 
> mammique <mammique@lamenagerie.com>
> -- 
> To UNSUBSCRIBE, email to debian-powerpc-request@lists.debian.org
> with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: