[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: ibook didn't detect hard drive

So the new kernel did the trick. But I have a new problem. When the installer went to make the hard disk bootable, it failed. I switched to the instalation shell and started trying to do it by hand.
This is partially solved so the following information might not be exact.

I use the command yabootconfig -t target
I get an error about /dev/hdc is an invalid device.

After googling around for a solution I found out that yabootconfig and ofpath do not seem to like it when the cdrom and hard drive are reversed. I think the guys said something about the cdrom being on hd and the hard drive being on ide0. They also said that the newer yaboot software didn't have difficulty with this arrangement. At this point I realized that the debian howto said the yaboot that came on the cd was old, so I assumed that the yaboot on root.bin is also old so I decided to update it with all new files. So I copied the files


to /usr/sbin

At this point I run yabootconfig and get back an error mktemp not found. So I copy make temp from the installation under /target and put it into /bin.

At this point I ran into another problem that just blows my mind. I decided not to solve it but simply go around. The jist of the problem, when I copy yabootconfig to /usr/sbin/yabootconfig it also writes over /usr/sbin/mkofboot and visa versa. This results with the files yabootconfig and mkofboot having the same contents. I have no clue why this happens, I just decided to copy yabootconfig into /usr/sbin and mkofboot into /bin which is higher up in the $PATH.

At this point running yabootconfig prints the error
mkofboot: hfsutils is not installed or cannot be found
mkofboot: Try --mount if Linux 2.4.20-ben5 supports HFS

At this point I stopped, have I gone down the wrong path by overwriting the yabootconfig and mkofboot files. I am worried that these particular files my have requirements that don't suite well fpr instalation, like dynamic linking and such. Is there an installation version of yaboot that doesn't have these requirements? Or maybe all these problems are really some other problem the I have created or missed.

Any input would be helpful as to where I go from here.

Mike Power
P.S. I am not subscribed to the list so you'll need to CC me

Diana Galletly wrote:

On Fri, 5 Dec 2003, Mike Power wrote:

Judging by the discussion it seems the kernel needs to be rebuilt.
Before I dive into the process I was hoping someone knew the exact
details of the kernel options needed to detect the new ibook hard
drive?  I am also going to have to look up information on how to change
either root.bin or linux.bin to the new kernel.  I know how to build
kernels I just don't know how to build a kernel that will be used for
installation, and I don't know where to put it.

Download a replacement kernel from


as described at


Bunzip2 it.  Move it to the same directory as your root.bin, yaboot and
yaboot.conf.  Rename it to linux.bin.

Then follow the installation instructions as previously.


Reply to: