[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: 2.6.0-test9 kernel on xserv

On Wed, 2003-11-19 at 22:23, Adam Done wrote:

The Complie went very well and compiled it without smp frist to make sure it runs.  When I do I get this:

Started krxtimod 15
Started krxiod 16
Started krxsecd 17

VFS: Cannot open root device "hde9" or unknown-block(0,0)
Please append a correct "root=" boot option
Kerel panic: VFS: Unable to mount root fs on unknown-block(0,0)
<0>Rebooting in 180 seconds...

This has been my bane with the 2.6.0-test kernels on the xserv ever since the beginning.  The correct partition I have been using with my 2.4.22 kernel is hda9.  But every time I try to boot into 2.6.0-test(x) I get this error every time, rather puzzeling.  I  have also with yaboot made the hda9 -> hdg9 inclusive and still no booting.  I  know one gets this when it does not have a boot partitioon but for some reason it will not reconize any letter I give it for booting into.  Thanks for the help.


My steps I  took:

1.  downloaded the 2.6.0-test9 from kernel.org
2.  unpacked the kernel
3.   rsync -avz --delete source.mvista.com::linuxppc-2.5-benh linux-2.6.0-test9/
4.  make pmac_defconfig
5.  make gconfig
    a.  the only change i made from the pmac_defconfig was adding xfs and afs to the kernel.. other than that everything else stayed the same
6.  saved config
7.  make-kpkg --append-to-version .xfs-xserv1 -rev Custom.1 kernel_image
8.  waited for the compile on my G4
9.  scp kernel-image-2.6.0-test9.xfs-xserv1_Custom.1_powerpc.deb to my xserv box
10.  dpkg -i kernel-image-2.6.0-test9.xfs-xserv1_Custom.1_powerpc.deb
11.  cd /boot
12.  mounted my bootstrap (it is where i keep all my kernels)
13.  cp the kernel over to the boot strap
14.  unmount bootstrap
15.  edited my yaboot.conf file with:



The root=/dev/hda9 is the actuall root partition now (i had switched the hds from hde being the first drive to hda to the first drive)

16.  ybin
17.  rebooted the box
18.  The last messages on the screen are on the top of the email.
19.  I tried this both with the hde9 and the hda9 and both give the same results.  Infact no matter what I change the hd to it won't work.

That is what I have been doing.  I really hope someone can help shed some light on this issue.  I have been trying for a long time to have both xfs and afs to run on the xserv and we really need it for all the work we are and will be doing here at the studio with digital imaging.

Reply to: