[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: 2.6.0-test9 kernel on xserv

On Wed, 2003-11-19 at 02:19, Benjamin Herrenschmidt wrote:
On Wed, 2003-11-19 at 11:24, Adam Done wrote:
> OK,
> I am totally at a loss.  I am having the bigest and toughest problem
> trying to complie a working kernel for the xserv.  I have been working
> on this straight since last friday and lost a lot of sleep trying to
> figure the right combo to have a working kernel.  Has anyone have any
> positive experience with this.  

Tried my tree with a pmac_defconfig ? (then eventually turning on SMP)

rsync from source.mvista.com::linuxppc-2.5-benh


The Complie went very well and compiled it without smp frist to make sure it runs.  When I do I get this:

Started krxtimod 15
Started krxiod 16
Started krxsecd 17

VFS: Cannot open root device "hde9" or unknown-block(0,0)
Please append a correct "root=" boot option
Kerel panic: VFS: Unable to mount root fs on unknown-block(0,0)
<0>Rebooting in 180 seconds...

This has been my bane with the 2.6.0-test kernels on the xserv ever since the beginning.  The correct partition I have been using with my 2.4.22 kernel is hda9.  But every time I try to boot into 2.6.0-test(x) I get this error every time, rather puzzeling.  I  have also with yaboot made the hda9 -> hdg9 inclusive and still no booting.  I  know one gets this when it does not have a boot partitioon but for some reason it will not reconize any letter I give it for booting into.  Thanks for the help.

Reply to: