[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

2.6.0-test7 (benh) cpufreq problem?

Hello together,

I own an PBG412.

I rsynced 2.6.0-test7 from source.mvista.com and compiled that kernel,
which worked with two minor problems.

1.) CONFIG_LOG_BUF_SHIFT was not choosable from within 'make
menuconfig', I set it to '14'. (Hope it's correct)
2.) CONFIG_PCNET32 I had to set to N for compiling.
3.) That plan B video stuff has to be disabled.

I tried cpufreq alone enabled as well as the recommended enabeling of
'powersave govenor' and 'userspace govenor'. 

Then I succeeded with make-kpkg.

After booting the new kernel, it stopped in any case at that openpic
message just at the beginning looking like

    openpic: enter
    openpic: timer
    openpic: external
    openpic: spurious
    openpic: exit

It's similar to what I reported a time ago after a MacOSX-upgrade (Panther). 
Benjamin Herrenschmidt recommended to upgrade my 2.4.* kernel which
solved the problem, which, as he explained short, was in some context
with cpufreq. 

BTW with my 2.4.23-benh cpufreq works for me now.

Question is if somebody got 2.6.0-test7 working with cpufreq enabled
or is that a common problem at that stage.

BTW if there is a better place to report this please tell me

THX and a nice day



Georg Koss

mailto: georg.koss@nextra.at

Reply to: