[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Minimal powerpc kernel, miboot users please test (Was Re: modularized powerpc kernel)

"Chris Tillman" <toff1@cox.net> writes:

> On Wed, Oct 22, 2003 at 11:15:03PM +0200, Sven Luther wrote:
> I tried booting this kernel with no success. I tried with miboot and BootX,
> and both of them seem to get stuck. The video never changes from the last 
> Mac screen after it reboots. I also tried with quik, and there it
> booted up to the point:
> NET4: Unix domain sockets 1.0/SMP for Linux NET4.0
> adb: starting probe task...
> EXT2-fs: unable to read superblock
> cramfs: wrong magic
> Kernel panic: VFS: Unable to mount root fs on 01:00
> I was using
>  root=/dev/ram
>  partition=6
>  ramdisk=/root.bin
>  append="video=ofonly load_ramdisk=1 ramdisk-size=8192"
> I guess this is because I'm asking the kernel to read root.bin off the
> disk partition, and it probably doesn't have the ide drivers compiled
> in.
> However, it didn't get much farther when I tried a kernel that did
> have drivers ... it read the partitions OK, but failed soon after 

You are trying to read the ramdisk of /dev/ram which can't work.
"root=/dev/fd0 load_ramdisk=1" would load from floppy respectively.

> usb.c: registered new driver wacom
> set_blocksize: b_count 1, dev ramdisk(1,0), block 1, from c0067bd8
> Kernel panic: VFS: Unable to mount root fs on 01:00
> I suppose this is just because quik doesn't load the ram up ahead of
> time?

Yep. You need a kernel with buildin ramdisk I guess.


Reply to: