[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Installation of debian on G5 pmac?

> Woody's yaboot is not new enough to work on G4s and G5s.  You need the
> newest yaboot from penguinppc.org. In fact, I'm not sure it's been
> tested with G5s yet.  
> According to Nick Lopez in a post on this list less than a week ago
> (didn't you already search the archives?), the kernel "hasn't survived
> contact witha G5 yet". Also, the powerpc kernel developer BenH hasn't
> gotten access to a G5 yet, so it's unlikely to work until he does.

Not exact ;)

I had access to a g5 for a short while. My current bk 2.4.23-pre, when
compiled for POWER4 with g5_defconfig will happily boot a G5 ;) Though
it will have some drawbacks:

 - No fan control: all fans ramp up to full speed (_very_ noisy)
after a couple of minutes
 - No cpufreq control, CPU boots at low speed (1.3Ghz iirc)
 - No SMP, only one CPU is booted
 - No sound

I will probably not have another G5 until at least 2 or 3 weeks from now
at which point I'll be for a few years an Australian guest citizen :)

My ability to continue working on the G5 kernel should be preserved despite
beeing an IBM employee, though I yet to have written confirmation of this.


Reply to: