[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Help to reproduce the bug (Was: Re: State of Ruby)

Copying to debian-powerpc mailing list. (Please Cc: me and/or the bug as
I'm not subscribed.)

Can anyone here help to reproduce this bug? Ruby 1.8 fails to build
packages with "stack level too deep" error on Debian PowerPC build
server (voltair), but works fine on Fumitoshi UKAI's Cube.

See more details below.

On Thu, Oct 02, 2003 at 01:50:37AM +0900, Fumitoshi UKAI wrote:
> > There is also #212282 which is more difficult and more important,
> > since it renders Ruby 1.8 unusable on PowerPC, which is an
> > officially released architecture. I have neither hardware nor
> > expertise to solve this problem, but I think it is important and
> > should be investigated and appropriately elevated to debian-devel
> > and/or ruby-core.
> I can't confirm this bug. It works fine for me.
>  # uname -a
>  Linux cube 2.4.18-newpmac #1 Mon Jun 9 03:10:07 UTC 2003 ppc GNU/Linux
>  # dpkg -l ruby1.8  ruby1.8-dev libruby1.8
>  ii  ruby1.8        1.8.0-2        Interpreter of object-oriented scripting lan
>  ii  ruby1.8-dev    1.8.0-2        Header files for compiling extension modules
>  ii  libruby1.8     1.8.0-2        Libraries necessary to run the Ruby
>  # ruby1.8 -e 'p a'
> -e:1: undefined local variable or method `a' for main:Object (NameError)
>  # ruby1.8 -rmkmf -e 'p Config::CONFIG["rubylibdir"]'
>  "/usr/lib/ruby/1.8"
> Note that ruby1.8 uses USE_BUILTIN_FRAME_ADDRESS for __builtin_frame_address
> and USE_BUILTIN_FRAME_ADDRESS is not defined when building ruby1.8.deb
> http://buildd.debian.org/fetch.php?&pkg=libgettext-ruby&ver=0.5.1-5&arch=powerpc&stamp=1064109677&file=log&as=raw
> Anyway, why does it looks like loading ruby 1.8 library in 
> "ruby1.6 install.rb setup"?
>  ruby1.6 install.rb setup
>  install.rb: entering setup phase...
>  /usr/lib/ruby/1.8/powerpc-linux/rbconfig.rb:22: stack level too deep (SystemStac
>         from /usr/lib/ruby/1.8/racc/rubyloader.rb:13:in `require'
>         from /usr/lib/ruby/1.8/racc/rubyloader.rb:13
>         from /usr/bin/racc:300:in `require'
>         from /usr/bin/racc:300
>  setup failed

I think that is a separate bug, probably due to some error in
debian/rules, such as this:

ruby install.rb clean 
make: ruby: Command not found

Anyway, in case of libdbi-ruby and mysql-ruby, for Ruby 1.6 packages,
1.6 libraries are loaded, and it builds successfully, and for Ruby 1.8
packages, 1.8 libraries are loaded and Ruby fails with stack level error:


ruby1.6 setup.rb config --with=dbi,dbd_pg,dbd_mysql,dbd_sqlite \
	--bin-dir=debian/tmp/usr/bin \
	--rb-dir=debian/tmp/usr/lib/ruby/1.6 \
entering config phase...
config done.
ruby1.8 setup.rb config --with=dbi,dbd_pg,dbd_mysql,dbd_sqlite \
	--bin-dir=debian/tmp/usr/bin \
	--rb-dir=debian/tmp \
setup.rb:588: warning: parenthesize argument(s) for future version
/usr/lib/ruby/1.8/powerpc-linux/rbconfig.rb:18: stack level too deep
	from setup.rb:17:in `require'
	from setup.rb:17
make: *** [build-ruby1.8-stamp] Error 1

Dmitry Borodaenko

Reply to: