[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: iSight & Airport station.



On Sun, Aug 24, 2003 at 06:50:09PM -0600, Jay Graves wrote:
> On Fri, Aug 22, 2003 at 11:34:29AM -0700, P Oscar Boykin wrote:
> > 1) You do have the video1394 module loaded correct?  It seems to be
> > using the raw1394 module for the iSight, I don't know if that is a
> > problem or not.
> 
> Yes I have those modules loaded, but to me it looks like the sbp2
> modules is getting the iSight, look at this dmesg output
> 
> ieee1394: Node 01:1023 changed to 00:1023
> ieee1394: Node 00:1023 changed to 02:1023
> ieee1394: sbp2: Reconnected to SBP-2 device
> ieee1394: sbp2: Node[02:1023]: Max speed [S400] - Max payload [2048]
> ieee1394: Device added: Node[00:1023]  GUID[000a270004022ac8]  [Apple
> Computer, Inc.]
> ieee1394: Node 02:1023 changed to 01:1023
> ieee1394: sbp2: Reconnected to SBP-2 device
> ieee1394: sbp2: Node[01:1023]: Max speed [S400] - Max payload [2048]
> ieee1394: Node 00:1023 changed to 02:1023
> ieee1394: unsolicited response packet received - np
> ieee1394: contents: ffc22520 ffc00000 00000000 94113866

It is kind of confusing (There are four Node changes up there).

Are you using a firewire harddrive already?  If you are not (or can do
without it for the moment) maybe you can rmmod sbp2 before putting the
iSight in?  Maybe then it will be okay.

If that does work, the obviously it is some bug in sbp2.

> > 2) I don't know what version of Coriander you are using.  The one in
> > stable is 0.22, which seems to be 1.5 years old.  Perhaps you want to
> > download the latest version (0.99.2), and compile it yourself.  (I think
> > you will also need the latest libdc1394.  Maybe this version will work
> > better.  I guess there is some chance you will also need a later version
> > of the IEEE1394 code: http://www.linux1394.org/download.html (which
> > means recompiling your kernel, and I don't know if there will be any
> > problems with their IEEE1394 code and the PPC, be careful).
> > 
> 
> I am running Debian unstable with coriander Version: 0.27.1-1
> libdc1394 Version: 0.9.1-2
> and the firewire modules in kernel 2.4.21
> 
> I will look at compiling the latest 0.99.2 version of coriander

Any luck with this?

POB.
-- 
boykin@pobox.com    http://pobox.com/~boykin    jabber: johnynek@jabber.org
fingerprint=159A FA02 DF12 E72F B68F  5B2D C368 3BCA 36D7 CF28
Read about net freedom: http://www.politechbot.com/

Attachment: pgp9cW2fox41r.pgp
Description: PGP signature


Reply to: