[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: new Apple symbols map (exposes kernel buglets?)

On Saturday 23 August 2003 6:25, Michel Dänzer wrote:
> On Sat, 2003-08-23 at 13:49, Frank Murphy wrote:
> > However, I don't want to move the 'extended' or 'laptop' into a
> > specific macintosh keymap, like you've done here in us.
> Why, what's the problem with that? macintosh/us is the basis for all
> macintosh layouts.

The problem is that by keeping the macintosh layouts separate from the PC 
layouts, there are fewer macintosh layouts than there could be.

> > Long-term, I'd actually like to increase the similarities between PC
> > and Apple keyboards,
> macintosh/us could be changed to include and modify pc symbols?

True, but I'd rather do that via the Rules component. I think it's a cleaner 
place to do that.

> > so get rid of the macintosh directory and be able to use
> > pc/us(105)+apple or pc/de+apple to specifiy an Apple keyboard (of
> > course, using the rules so that configuration is similar to what you
> > have here).
> Don't (some) international Mac keyboards have specific modifications vs.
> their PC counterparts though?

I don't think there are that many. There were some Apple keyboards that had 
the Euro symbol on the 2 instead of the E, but I think they're pretty close. 
But I'd want to check before making that change, of course.

> > > BTW, where do you get the Multi_key definition from? Can't seem to find
> > > it here.
> >
> > What do you mean? Where do I define it (in the apple file)?
> No, you don't. Maybe you get it from a pc symbols file?

Arg. I'd had it in my .Xmodmap for a long time, but I had added it to apple. 
Just sent the wrong version. I've attached the change here.

> > > Speaking of bugs, fn+command generates the same keycode as the eject
> > > key in X here, but not in console (showkey shows several keycodes for
> > > the eject key) - maybe related to the keypad equal bug you fixed
> > > recently?
> >
> > I don't have an eject key here,
> Your F12 key doesn't work as eject?

No. It doesn't have the Eject symbol on it, so I never tried. Doesn't do 
anything at all though. I'm running pmud and not pbbuttonsd though. I 
couldn't get pbbuttonsd to change my volume. And I have an original iBook.

> > but I imagine it's related to X's KP_Equal bug.
> So was the fix specific to KP_Equal, or could it fix all such keys?

The fix was specific to KP_Equal, but David Dawes seemed to think that there 
were more like it. I think there's a new and old keyboard driver, but the new 
isn't finished or being worked on.


Reply to: