[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: plplot buildd fails on powerpc

* Michel Dänzer <daenzer@debian.org> [2003-06-04 11:33]:

> On Wed, 2003-06-04 at 09:31, Rafael Laboissiere wrote:
> > 
> > The buildd of my plplot package is strangely failing for the powerpc
> > architecture and I can not figure out from the buildd log where the problem
> > is.
> >From
> http://buildd.debian.org/fetch.php?&pkg=plplot&ver=5.2.1-13&arch=powerpc&stamp=1054680644&file=log&as=raw:
> make[6]: Entering directory `/build/buildd/plplot-5.2.1/bindings/octave/PLplot'
> make[6]: Nothing to be done for `install-exec-am'.
> /bin/sh ../../../mkinstalldirs /build/buildd/plplot-5.2.1/debian/tmp/usr//PLplot
> mkdir -p -- /build/buildd/plplot-5.2.1/debian/tmp/usr//PLplot
>                                                   ^^^^^^^^^^^
>  /usr/bin/install -c -m 644 use_plplot.m /build/buildd/plplot-5.2.1/debian/tmp/usr//PLplot/use_plplot.m
>  /usr/bin/install -c -m 644 plplot_octave_path.m /build/buildd/plplot-5.2.1/debian/tmp/usr//PLplot/plplot_octave_path.m
>  /usr/bin/install -c -m 644 toggle_plplot_use.m /build/buildd/plplot-5.2.1/debian/tmp/usr//PLplot/toggle_plplot_use.m
> [...]
> dh_movefiles -a --no-package=libplplot5 
> dh_movefiles: debian/tmp/usr/share/octave/site/m/PLplot not found (supposed to put it in octave-plplot)
> Looks like share/octave/site/m is lost somehow in the bindings/octave/
> build directory?

Yes, this is where the building fails, but the reason is that actually
configure fails to set the Octave installation paths:

./configure --prefix=/usr --mandir=/usr/share/man --enable-tcl       \
                    --enable-tk --enable-gd --enable-dyndrivers      \
                    --disable-static --enable-python --enable-octave \
                    --enable-gnome --with-double --disable-linuxvga  \
                    --infodir=/usr/share/info --with-freetype        \
                    --without-rpath --with-prebuiltdoc
checking Octave version... 2.1.49
checking Octave prefix... /usrerror: Permission denied
checking Octave m dir... sed: -e expression #1, char 34: Unknown option to `s'

The error message above only appears on powerpc.  The usual log should be
like this:

checking Octave version... 2.1.49
checking Octave prefix... /usr
checking Octave m dir... /usr/share/octave/site/m

> > I would need access to a powerpc Debian unstable system with all
> > build-dependencies of plplot installed. Is this mailing list the right 
> > place for this kind of request odr should I ask in debian-admin?
> The latter I think.



Reply to: