[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Getting X server running

On Wed, Mar 12, 2003 at 12:03:04PM -0800, Pietro Calogero wrote:
> Dear Chris,
> Just loaded Woody onto PowerMac 9500 for the first time. I have 2 
> problems I need help with, and based on reading of Debain archive, I 
> think you could help with at least one, and give suggestions for the other:
> #1 Problem: Cannot update to kernel 2.4x. I used deselect, chose kernel 
> 2.4.18-powerpc-smp, proceeded through the install, everything seemed to 
> go fine, but when I reboot I still get the default 2.2.20 kernel. It 
> seems like a different process than on i386 machines, where you have to 
> add a symlink and run LILO again so that you partition isn't rendered 
> unbootable. I have no idea how quik behaves, or if I should install 
> BootX, or how to install BootX and get it to replace quik.

quik and yaboot were both modeled on silo, which was modeled on lilo I
think. Their .conf files are all very similar; all you need to do to make
the different kernel active is add an image section in the .conf file
for it, run quik, and then type that image name when the quik prompt
comes up. Or, if you can't see the quik prompt at boot (I can't on my
9500), make it the default image in quik.conf. For details, man quik.conf.
Remember, though, quik doesn't grok symlinks (lilo and yaboot do).

The other option is to use BootX, if you still have MacOS installed.
I am able to boot 2.4.18-powerpc from the Debian archive with BootX,
HOWEVER the video doesn't work, like it does with 2.2.20.

I had one configuration working using the command boot parameter 


But, I didn't get it to work tonight :(

> Unfortunately, I may not be able to tackle problem #2 until I resolve 
> problem #1. You may just want to paste in links to documentation I 
> should read. So far as I know it is not covered in the Debian Reference, 
> nor the Installing Debian GNU/Linux 3.0 For PowerPC, nor can I find any 
> advice in the lists.debian.org archive.
> #2 Problem: Cannot get X server running.
> Video Card: ATI XCLAIM GA with Mach64 GX chip, 2MB video RAM, inserted 
> into PCI slot F2.
> Note: this video card seems to have various names. Maybe it should just 
> be called "ATI Mach64GX", maybe "ATY XCLAIM", maybe "ATI XCLAIM GA", 
> maybe "ATI888GX00". See below.
> Apple System Profiler identified it thus:
> Slot F2: display card
> Type: display
> Model: ATY, 88800GX
> ROM#: 113-33200-110
> Reviz: 3
> Vendor I.D.: 1002
> dmesg output identifies it thus:
> ...
> atyfb: mach64GX (ATI888GX00) [0x00d7 rev 0x03] 2M VRAM, 14.31818 MHz 
> XTAL, 135 MHz PLL, 50 MHz MCLK

This line is identical on mine, except mine is rev 0x02

> atyfb: monitor sense=0, maps to mode 20
> Console: switching to colour frame buffer device 128x48
> fb0: ATY Mach64 frame buffer device on /bandit@F4000000/ATY, XCLAIM@F
> ...
> (I notice in the second line, that the 'aty framebuffer' does not seem 
> to be sensing a monitor, if I read that line correctly. If so, that may 
> be a clue to the "(EE) No devices detected" Fatal server error.)

No, I would guess sense=0 is just the alternative to sense=1.  That is
probably the 17" monitor's sense line.  It looks like to me that your
devices are being detected correctly.
> Based on the above info and your recommendation in the archive, I used 
> dpkg-reconfigure to revise my /etc/X11/XF86Config-4 from 'generic 
> device' to this:
> Section "Device"
>    Identifier "ATI mach64GX"
>    Driver "ati"
>    Option "UseFBDev" "true"
> EndSection
> Section "Device"
>    Identifier "Radius PrecisionView 17"
>    HorizSync 31-64           [obtained from mfr's website]
>    VertRefresh 50-120        [obtained from mfr's website]
>    Option "DPMS"
> EndSection
> Previously, when I tried startx, it returned:
> ...
> (II) Loadmodule: "vga"
> ...
> (II) VGA: Generic VGA driver (version 4.0) for chipsets: generic
> (EE) No devices detected.
> Fatal server error:
> no screens found
> Now, when I try startx, it returns:
> ...
> (II) ATI: ATI driver (version 6.3.6) for chipsets: ati
> (II) R128: Driver for ATI Rage 128 chipsets ATI Rage 128 RE (PCI),
>    [12 more chipsets are listed, all of them of the ATI Rage 128 group, 
> none of them ATI Mach64]
> (II) RADEON: Driver for ATI Radeon chipsets: ATI Radeon QD (AGP) [etc; 
> no Mach64]
> (EE) No devices detected.
> Fatal server error:
> no screens found
> Sorry for the long, unsolicited email. Tried to only include the info 
> that seemed necessary for diagnosis, but I am a newbie. Feel like one of 
> those protohumans at the beginning of 2001: A Space Odyssey. Especially 
> when facing a black, monolithic screen.
> Pietro Calogero

It's fine to post detailed questions like this to the list;
in fact I'll copy it on my reply. Especially when you indicate 
you've already searched for the answer. The nice thing about 
having a community of hobbyists around is that someone usually
knows something.

I do remember at least two people having success with getting
both processors going on the 9500, but there's some kind of
trick involved to prevent MacOS from taking a processor. You're 
not there yet, anyway.

For X, I can't be of much help. I made a little progress by setting
the bit depth to 8, it said the card couldn't do 15. But even
though it does detect the card accurately, it doesn't find any
usable screens. Hopefully someone has a working XF86Config-4. 

"The way the Romans made sure their bridges worked is what 
we should do with software engineers. They put the designer 
under the bridge, and then they marched over it." 
-- Lawrence Bernstein, Discover, Feb 2003

Reply to: