[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problems starting the X-server

Michel Dänzer wrote:

On Don, 2003-02-20 at 08:12, Reto Stalder wrote:
I have an iBook 2.2. My problem is, that the X-server does not start. The
screen turns black and stays like this. There is no way to return to the
console. The only way to access the machine is to login via ssh from a
foreign host. I've installed it following the instructions on mij's page. I
have tried out the combinations of two kernels and two versions of Michels
- self compiled ben6-kernel
- precompiled ben5-kernel
- Michels X-server version 2002.12.05-4
- Michels X-server version 2003.07.02-2
The effect is allways the same. There must be a problem with the radeon
driver, but I can't fix it. I haven't found any previous posts on this

You didn't look hard enough. ;)

He's right. Try searching the archives for this thread: X config on 14 inch 700mhz ibook

I had the same problem as you and this thread fixed it.

Fatal server error:
could not open default font 'fixed'

Make sure xfonts-base (or even better x-window-system-core) and xfs are
installed (or uncomment the direct FontPaths in XF86Config-4).

The black screen is because radeonfb fails to restore the display after
the server aborts for some reason.

And don't forget to install a Windowmanager.

Reply to: