[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Initializing linux partition on install results in reboot.

On Wed, 12 Feb 2003, Christian Walther wrote:

> Hi Joel,
> Joel Schander <jschande@cs.cuc.edu> schrieb am 11.02.03 20:22:29:
> > 
> > Attempting to Initialize and Activate Swap Partition resulted in the box
> > apparently sitting idle for about three minutes, then rebooting. 
> As strange as this may sound, you might have a memory problem. You
> should check the DIMMs by removing all of them, and trying to boot
> the machine with just one DIMM installed.  I had the problem some
> time ago, having 4x128MB+2x32MB(+16MB onboard) installed in my Umax
> Pulsar I ended up with exactly the same strange behaviour. I
> reinitialised the partition map (although this is something you
> should try, too), removed all disks possible because I thought it
> could be some kind of misbehaviour of one of the disks etc. I got
> the DIMMs on eBay and one day I received an eMail of the seller,
> telling me that one of the DIMMs might be faulty. I ran the test
> above and found out that one DIMM actually wasn't working.
> Hope that helps
> Christian

Thank you, Christian.

Sure enough -- it appears my RAM is goofy. The root floppy fails to load
with one of the DIMMs, and the other is reporting a mere 13 MB RAM --
it's a 32-MB DIMM [0] -- but things boot just fine, and I don't get the
reboot while trying to partition the hard disk. Consequently, I
sucessfully partitioned the disk, checked for bad blocks, and continued
with the install.  I ran into some problems that appear to be the result
of my mistaking an i386 ISO for a PowerPC one, but am rectifying that as
I type -- thank you Oregon State. :)

(Thanks to Simon and Chris, as well, for the suggestions on the
partition map -- I wiped it clean and manually reformatted it without
the driver partitions. I forgot to mention in my initial post that I
thought the problem might have been the disk, but swapped in another and
decided that was not the case.)

[0] Actually, checking LowEndMac.com, I see Umax's SuperMac 600 series
had 16MB onboard, just like your Pulsar. If I'm only having 13 MB
reported, perhaps that is where the problem actually lies, though that
doesn't necessarily then explain why I experience different behavior
depending on which add-on DIMM I use, or why the machine would stop
autorebooting after removing one of them.


Reply to: