[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: unresolved symbol errors, trying to run XFree86 -configure

Michel Dänzer (daenzer@debian.org) wrote:

> On Don, 2003-02-06 at 13:14, Ryan Singer wrote:
> > (EE) R128(0): No Display subsection in Screen section "Default Screen"
> > for depth/fbbpp 8/8
> You probably don't want to use depth 8? Add
> 	DefaultDepth	24
> to the Screen section (or 16 or 15, and make sure there's a matching
> display subsection).

Ack! Tried that too. Now I get the following in the error log:

[drm] failed to load kernel module "r128"
(II) R128(0): [drm] drmOpen failed
(EE) R128(0): [dri] DRIScreenInit failed.  Disabling DRI.
(II) R128(0): Memory manager initialized to (0,0) (1024,8191)
(II) R128(0): Reserved area from (0,768) to (1024,770)
(II) R128(0): Largest offscreen area available: 1024 x 7421
(==) R128(0): Backing store disabled
(==) R128(0): Silken mouse enabled
(II) R128(0): Using XFree86 Acceleration Architecture (XAA)
	Screen to screen bit blits
	Solid filled rectangles
	8x8 mono pattern filled rectangles
	Indirect CPU to Screen color expansion
	Solid Lines
	Dashed Lines
	Scanline Image Writes
	Offscreen Pixmaps
	Setting up tile and stipple cache:
		32 128x128 slots
		32 256x256 slots
		16 512x512 slots
(II) R128(0): Acceleration enabled
(II) R128(0): Using hardware cursor (scanline 1540)
(II) R128(0): Largest offscreen area available: 1024 x 7419
(II) R128(0): Direct rendering disabled

The screen flashes w/ some colored lines and boxes, then goes black
and the breathing-power-button-light on the front blinks until I
hold cmd-ctrl-alt-del to get back to the shell.

I'm losing hope!

Ryan Singer :: http://feltpresence.com

"No king, no government, no parliament ever extended to
 the people more rights than the people insisted upon."
   - Terence McKenna

Reply to: