[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Can't boot with new kernel

On Mon, Dec 30, 2002 at 07:48:43AM -0500, Olivier Gaumond wrote:
> --- Benjamin Herrenschmidt <benh@kernel.crashing.org> a écrit : > On Mon,
> 2002-12-30 at 03:00
> > Does it work any better with miBoot or BootX ? (Also strip the kernel
> > image). quik has known issues with too big kernel images and doesn't
> > quite support zImages well.
> I tried to strip the kernel with 
> $ strip /boot/vmlinux-2.4.19
> and the kernel size is now about the same size (under 3Mb) than my 2.2.20
> kernel and I get the same error on boot.
> Maybe I should try miBoot or BootX, however MacOS is not installed anymore and
> I don't have any MacOS CD, all I have is an Apple System Disk.  I did not find
> much information about miBoot, anybody knows where should I look?

miBoot is what's used on the Debian rescue/install floppies. So you
could replace the kernel on one of those, using the Replacing Kernel
on the Rescue Floppy install manual instructions, to give it a
try. (If that works, you could then change the boot parameters on the
floppy to boot your system instead of the ramdisk installer - and
you'd always have to use the floppy to boot with.)

Otherwise you can download System 7.5.3 from apple.com.

|            Chris Tillman        tillman@voicetrak.com          |
|                  To HAVE, GIVE all TO all (ACIM)               |

Reply to: