[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Can't boot with new kernel

On Sun, Dec 29, 2002 at 01:45:04PM -0500, Olivier Gaumond wrote:
> In the last two weeks I tried every possible way I could imagine to
> compile a new 2.4.19 kernel for my PowerComputing PowerTower Pro.
> Whenever I try to boot with this new image I get the following output:
> copying OF device tree...done
> Calling quiesce ...
> returning 0x00000000 from prom_init
> At first I tought that there might be a problem with the kernel source
> which is not adapated for PowerPC.  However I tried with source from
> different places (ppckernel.org, penguinppc.org, kernel.org) and using
> the packages from Debian with the powerpc patch.  I have also tried to
> install pre-compiled image.  I also tought that the problem could come
> from my configuration, however I tried using the same configuration I
> have now with the 2.2.20 kernel which comes from the debian
> installation without success.  (I copied /boot/config-2.2.20-pmac to
> /usr/src/linux/.config and run make oldconfig or make menuconfig).
> Maybe I do something wrong while making or installing the new kernel.
> These are the steps I took
> 1. make menuconfig
> 2. make clean
> 3. make dep
> 4. make
> 5. make modules
> 6. make modules_install
> 7. cp /usr/src/linux/vmlinux /boot/vmlinux-2.4.19
> 8. cp /usr/src/linux/System.map /boot/System.map-2.4.19
> 9. add an entry in /etc/quik.conf that points to /boot/vmlinux-2.4.19
> 10. run /sbin/quik 
> 11. reboot
> There is certainly something I forget because I always get the same
> result: the prom_init error message)

Do you have video=ofonly in your quik.conf? IIRC on my oldworld, the
2.2.20 kernel needed video=ofonly but the 2.4 kernel didn't work until
I took that out.

|            Chris Tillman        tillman@voicetrak.com          |
|                  To HAVE, GIVE all TO all (ACIM)               |

Reply to: