[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

problems with woody quik on beige g3 300

So, I picked up a beige G3 300 from eBay.  It has OpenFirmware 2.4, and
has a Rage 64 Pro graphics chip.

I'm trying to complete an install of woody on this machine.  BootX works
great, but I've had no luck with quik.  Specifically, the symptoms are
that it just sits there on reboot -- not even a monitor signal or any
error message.  Boot into OF, type 'boot', and I see 'unable to open
ata/ata-disk@0:0'.  (I've tried every conceivable combination for
boot-device, including substituting 0:0 for 0:2, see below, and been
through every value for load-base).

The machine's configuration is that there's a fresh disk on ide0's
master, and the MacOS 9.2 disk is slave on ide1.  MacOS will boot fine.

I ran SystemDisk in order to set up booting to OF, as per instructions.

I've spent a significant amount of time searching this list and other
sources and can't find anything that successfully tells me the answer. 
If anyone has beaten this particular problem, I'd love to hear from

Here's the partitioning of the disk:

        #                    type name                  length  
base      ( size )  system
dump: name /dev/hda len 8 
/dev/hda1     Apple_partition_map Apple                     63 @
1         ( 31.5k)  Partition map
/dev/hda2         Apple_UNIX_SVR2 root                12582912 @
64        (  6.0G)  Linux native
/dev/hda3         Apple_UNIX_SVR2 var                  8388608 @
12582976  (  4.0G)  Linux native
/dev/hda4         Apple_UNIX_SVR2 swap                  901120 @
20971584  (440.0M)  Linux swap
/dev/hda5         Apple_UNIX_SVR2 other              134217728 @
21872704  ( 64.0G)  Linux native
/dev/hda6              Apple_Free Extra                 211056 @
156090432 (103.1M)  Free space

Running quik -vf gives;

# quik -vf
Second-stage loader is on /dev/hda2
Config file is on partition 2
Writing first-stage QUIK boot block to /dev/hda2
Making /dev/hda2 bootable (map entry 2)
Writing block table to boot block on /dev/hda2


-- Edd (currently stuck with BootX but doesn't want to be)

Attachment: signature.asc
Description: This is a digitally signed message part

Reply to: