[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

a try at dri

hi all,

I just got an 800mhz TiBook and don't quite have X working yet...
I've read the last couple months of this list, and wow, lots of juicy
info. (you guys rock!).

Short story is, X starts, but the screen is wavy and the cursor is
shadowed about 2 inches to the right.  (ring any bells?)

Here's the long story:

I got the kernel src from benh's rsync.  Took the default configuration,
except deselected the radeon and ati dri drivers, but left the dri
support in.  make-kpkg'd me a new kernel, rebooted and everyting's fine.
(after fixing that #^%$%* ADB keymap).

Got the dri-trunk stuff from Michael Daenzer and built the radeon and
ati dri drivers.

Tried both of Michael's /usr/local binaries and branden's Xfree 4.2
binaries(from people.debian.org).

Added the ModulePath to my XF86Config-4:
        ModulePath      "/usr/X11R6/lib/modules-dri-trunk"
        ModulePath      "/usr[/local]/X11R6/lib/modules

Loaded the dri module in the module section (and all the others in the
example config)

Used this monitor section:
Section "Monitor"
        Identifier      "TiBook Panel"
        HorizSync       30-70
        VertRefresh     55-65
        Option          "DPMS"

        Mode "1280x854"
                # D: 79.815 MHz, H: 51.963 kHz, V: 60.003 Hz
                DotClock 79.816
                HTimings 1280 1296 1408 1536
                VTimings 854 855 858 866
                Flags    "-HSync" "-VSync"

        Mode "1152x768"
                # D: 64.994 MHz, H: 44.154 kHz, V: 54.781 Hz
                DotClock 64.995
                HTimings 1152 1178 1314 1472
                VTimings 768 771 777 806
                Flags    "+HSync" "+VSync"


modprobe'd agpgart.

I tried launching X at 16,24 bpp each at 1280x864, 1024,768.  Each time,
the same wavy version of the X startup screen appeared.  I also tried
using the driver set to "radeon" and "ati" (both using the FB option)

The XFree log was pretty clean,
Its using the dri-trunk modules:
(II) Loading /usr/X11R6/lib/modules-dri-trunk/extensions/libglx.a
(II) Loading /usr/X11R6/lib/modules-dri-trunk/drivers/radeon_drv.o

The only EE came here:
(II) Module int10: vendor="The XFree86 Project"
        compiled for 4.2.0, module version = 1.0.0
        ABI class: XFree86 Video Driver, version 0.5
(II) RADEON(0): initializing int10
(II) RADEON(0): No legacy BIOS found -- trying PCI
(EE) RADEON(0): Cannot read V_BIOS (5)
(WW) RADEON(0): Video BIOS not detected, using default PLL parameters!
(II) RADEON(0): PLL parameters: rf=2700 rd=67 min=12500 max=35000;

It also refused my 1280x864 setting:
(II) RADEON(0): Not using mode "1280x864" (no mode of this name)
(--) RADEON(0): Virtual size is 1152x768 (pitch 1152)
(**) RADEON(0): Mode "1152x768": 65.0 MHz, 44.2 kHz, 54.8 Hz
(II) RADEON(0): Modeline "1152x768"   65.00  1152 1178 1314 1472  768
771 777 806 +hsync +vsync

The drm init seemed to go well:
drmOpenDevice: minor is 0
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 7, (OK)
drmOpenDevice: minor is 0
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 7, (OK)
drmOpenDevice: minor is 0
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 7, (OK)
drmGetBusid returned ''
(II) RADEON(0): [drm] created "radeon" driver at busid "PCI:0:16:0"
(II) RADEON(0): [drm] added 8192 byte SAREA at 0xe302e000
(II) RADEON(0): [drm] mapped SAREA 0xe302e000 to 0x3001a000
(II) RADEON(0): [drm] framebuffer handle = 0xb8000000
(II) RADEON(0): [drm] added 1 reserved context for kernel
(II) RADEON(0): [agp] Mode 0x07000211 [AGP 0x106b/0x002d; Card
(II) RADEON(0): [agp] 8192 kB allocated with handle 0xe3031000
(II) RADEON(0): [agp] ring handle = 0x00000000
(II) RADEON(0): [agp] Ring mapped at 0x32047000
(II) RADEON(0): [agp] ring read ptr handle = 0x00101000
(II) RADEON(0): [agp] Ring read ptr mapped at 0x3001c000
(II) RADEON(0): [agp] vertex/indirect buffers handle = 0x00102000
(II) RADEON(0): [agp] Vertex/indirect buffers mapped at 0x32148000
(II) RADEON(0): [agp] AGP texture map handle = 0x00302000
(II) RADEON(0): [agp] AGP Texture map mapped at 0x32348000
(II) RADEON(0): [drm] register handle = 0xb0000000
(II) RADEON(0): [dri] Visual configs initialized

Any ideas?


To UNSUBSCRIBE, email to debian-powerpc-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: