[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Finally got debian installed, X configured, and am locked out of Linux

On Tue, Jul 02, 2002 at 06:40:32PM -0500, Bert Knabe wrote:
> On Sunday, June 30, 2002, at 11:15  PM, Chris Tillman wrote:
> >
> >By switching to a console, you can at least try more often. To get
> >from X to a console, use Control-Option-F1 thru F6. (X should be
> >running in F7). If you can't get in through the console with your
> >root password, you'll have to boot with the installer floppy again
> >to fix it. (I can help offline if that's required.)
> If I can get X going again, I'll remember those keystrokes (actually, 
> I've printed them out :). I eventually checked the "No Video" box in 
> BootX. Linux tried 3 times to start the GUI (with improper settings), 
> then zapped me back to the command line. I then, perhaps stupidly, 
> deleted the XF86Config file and ran anXious. I am now back where I 
> started, with the server being killed because no correct modes are 
> found. I think I've figured out why, but I'm not sure. At this point I 
> might be drifting into areas that properly go on the main Debian list, 
> but my video card is Mac only, so I think I'm still proper here. :)
> Here is what I think I've figured out, and what I did that succeeded in 
> starting X (I think - haven't had time to go back and check try again).
> Originally, when I tried to startx, I would get a message saying I 
> needed a "Screen" section for "fbdev" in my XF86Config. I would just 
> change "accel" to "fbdev" and go on. That would get me a message that no 
> correct modes could be found. Eventually, I manually entered a second 
> "Screen" section into XF86Config for "fbdev", leaving the section with 
> "accel" alone. The GUI started, but when I attempted to login, it always 
> claimed the password was wrong. If my username hadn't typed in 
> correctly, I'd think my keymap was hosed in GUI mode.

Well when you got this far (I think you're referring to the gdm login screen),
then you had the X server running. After you login, you would be under Gnome 
and a window manager (something eles to look forward to getting working).
> I'm beginning to wonder if anXious might be misconfiguring for my video 
> card. I have an ATI XCLAIM3D 4meg bought in March 1997. According to 
> anXious, I have a Mach64 (chipset?). I think that is a newer chipset, 
> but I'm not sure. I'm going to try to find out from ATI. It is driving a 
> Gateway Vivitron 15 monitor, which I don't have the specs for.

Mach64 sounds right.

I've run across 2 issues with the X server on Macs in version 4. Both are 
with NewWorlds, but the same issue might affect you. 1, For the iMac I 
make the Horizontal sync 58-62, because it really wants to be 60 real bad.
And I have to add a line for the BusID in the Device section. To find 
the number to enter, you look at the output of lspci for your video card.
On my Oldworld, I see 

00:11.0 VGA Compatible controller: ATI Technologies Inc 3D Rage I/II 215GT [Mach64 GT] (rev 41)

>From that, I know the BusID line would have to be

	BusID		"PCI:00:17:00"

(because the lscpi output is in hex, one 16 + one 1 = 17)

I don't know, this may be what you're missing too. I looked in the archives
but I didn't find any XF86Config files you sent; I thought you had sent one.

Anyway, assuming when you boot in you can switch to a console, you can take 
a look at the config and try lspci.

*------v--------- Installing Debian GNU/Linux 3.0 --------v------*
|      <http://www.debian.org/releases/woody/installmanual>      |
|   debian-imac (potato): <http://debian-imac.sourceforge.net>   |
|            Chris Tillman        tillman@voicetrak.com          |
|                   May the Source be with you                   |

To UNSUBSCRIBE, email to debian-powerpc-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: