[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: SMP Kernel

>Perhaps a little more light to this point. The Asante (DEC/Tulip chipset) 
>ethernet card, which is now set to eth0 and is corresponding to the one and 
>only configuration in /etc/network/interfaces doesn't work after reboot (no 
>ping). dmesg prints that the NIC is set up to 10baseT??? After disconecting 
>the patch cable and replug, everthing works fine. But that's not funny, 
>replugin every debian/GNU Linux Box after reboot?!?!

About this specific problem, you should probably report it to Jeff
Garzik who maintains the tulip driver.

>This three lines of hardcore information is missing with every pmac smp 
>kernel. It look like it's true. Because of problems with quik I set up 
>debian/GNU Linux from the start. And after I rebooted with the kernel-image-
>2.4.18-powerpc-smp and with quik I got 2 Tux (2 cpus in /proc/cpuinfo)!!!

Well, I though it was on some FAQ, you are right, we may want to be more
informative about it, though I'm not sure what is the right place for
this information. Maybe in Configure.help ? I'm thinking about a way that
would eventually allow to catch the CPU in that case, though I'm not sure
it will work reliably. More generally, BootX tends to be more reliable
with earlier MacOS versions, possibly because some of the hacks it needs
to do its magic don't work properly with newer MacOSes.

>If I had this 3 lines of information 3 month ago it would have saved me at 
>least 2 weeks of trying. PLEASE get this 3 lines into the dselect info with 
>every pmac smp kernel image!!! If you haved guessed right now, some Mac 
>Users who like to try Linux might be suspicious and like to boot from MacOS 
>(BootX) into Linux. And will be frustrated if the MP doesn't work ;-)

Well, fill a bug report about dselect, I'm not a debian package maintainer ;)
>As I said I got a working MP setup and lost it when I tried to compile a 
>custom kernel. Somehow I must have lost the quik bootloader. I tried at 
>least 4 times to set it back again without success. Neither quik nor 
>quikconfig worked. Every reboot brought up MacOS from /dev/sdb instead of 
>debian/GNU Linux from /dev/sda. But the base-config quik bootloader does 
>Where's the diffrence? 

I didn't touch quik for ages, though I plan to resume work on it sooner or
later, in the meantime, you'd rather ask on the debian-ppc mailing list
about that.
>Thank's for your great help!

To UNSUBSCRIBE, email to debian-powerpc-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: