[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Device name for internal modem on new G4 machine?


The good news (for me, anyway) is I've finally achieved some level of success in installing a base system on my new Power Mac G4. (Hurrah!)

The bad news is I can't figure out what the device name for my internal modem is. I need it, of course, to download the rest of Debian.

First I tried searching my startup log with "dmesg | grep -i modem", but there was no reference to a modem.

Then I went searching through the mail archives to see what other people have asked and was prompted by one message to type "modprobe macserial", so I tried that. The result of entering the command was:

macserial: i2c-modem detected, id= 1
PowerMac Z8530 serial driver version 2.0
tty00 at 0x305bo20 (irq=22) is a Z8530 ESCC (internal modem)
tty01 at 0x3062000 (irq=23) is a Z8530 ESCC

"Okay", I thought, "my modem is tty00". Unfortunately I didn't see a device by that name in /dev, and on a whim I tried in in my ppp configuration file and it didn't work.

1) So how do I find out the device name of my modem?

Also on a whim, I typed "modprobe macserial" a second time. This time there was no output. This implied to me that perhaps macserial was not initially loaded at startup.

2) Do I have to manually load macserial every time? We know that can't be true. ;-) How do I make sure this module is loaded automatically?

As always, if there is any documentation on this anywhere, please just send me there to read it.

Thanks for all your help!

-- Bill
Reply to: