[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: PM 7500 won't install s/w

on 13/02/2002 22:59, Chris Tillman at tillman@azstarnet.com wrote:

> On Wed, Feb 13, 2002 at 11:19:32AM -0500, simonraven@mac.com wrote:
>> on 12/02/2002 23:16, Chris Tillman at tillman@azstarnet.com wrote:
>> hmm, i'm having a similar problem, but related to the update install. here's
>> the thing:
> 'update install'? You mean you're upgrading from potato to woody?

no, just from the equivalent of the floppies (installing stuff from the RAM
disk) to making it a little more useable (to my POV anyway)
>> i have an HFS hard drive that i've downloaded stuff from the FTP mirror, and
>> i've mirrored it on the drive. now, i can mount it, and i can cd thru the
>> directories, but when i do dselect, it can't find the s/w, and i get errors.
>> i've configured the mtab, fstab, and apt things, and i still can't dselect.
>> i'm NOT on a network, and i've managed to install a few things thru dpkg,
>> accessing that HFS partitioned drive, including some pppoe s/w needed to
>> access the net thru this comp. but as u know, thru dpkg, it's a long
>> process, and i'm a newbie (on my 3rd day :-)), and i have to keep track of
>> the dependencies, conflicts, and so on by hand. which is confusing the hell
>> out of me.
> apt-get is what dselect uses under the covers; dselect really just
> provides a UI. So, you can do your tests with commands like
> apt-get install pppoe
> and it will also get everthing needed to satisfy dependencies.

i'm quite aware of the usefulness, but it's not getting anything off what i
put in fstab (see below)
>> ok, what i did (thru apt-setup - which btw, isn't being found anymore. (???)
>> i think it got deleted, but i haven't done any deletions of files. i don't
>> know how to yet) was this:
> Most likely, you tried to invoke apt-setup as a non-root user. Since
> only root can modify /etc/apt/sources.list, it only makes sense to run
> apt-setup as root, and it's found in an sbin directory (sbin's are not
> on non-root user's PATHs).

i've been doing everything as root. i quickly realised that i needed to be
so after a few tries with the installers, heh.
>> in /etc/apt/sources.list,  i have : deb file:/mnt/debian
>> and i've tried various things like file:/mnt, file:/debian,
>> file:/mnt/whatever. u get the idea.
> Although I haven't tried this, I suspect for a proper URL you need a
> couple more slashes: file:///mnt/whatever.

i did, and it gave me the same errors. in the apt-setup (which i dunno where
it went, i type apt-setup and it tells me not found - although i might have
been doing it as ~ and not /) it shows "file:/" and not "file:///" - despite
what i've seen in browsers for years. although the setup for fstab may have
not been done well, so the errors pop up.

>> in blank fstab i have : /dev/sdb6 hfs 0 0
> ^
> Might help to put 'defaults' as options here

good idea, i'll try that. i wasnt sure what to put there, but i had a
feeling i should. thanx.

it's nice to be able to talk with someone slowly, instead of in a chat
situation. i like IRC, but sometimes it's not conducive to slow thought.


Reply to: