[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: PM 7500 won't install s/w

On Wed, Feb 13, 2002 at 11:19:32AM -0500, simonraven@mac.com wrote:
> on 12/02/2002 23:16, Chris Tillman at tillman@azstarnet.com wrote:
> hmm, i'm having a similar problem, but related to the update install. here's
> the thing:

'update install'? You mean you're upgrading from potato to woody?

> i have an HFS hard drive that i've downloaded stuff from the FTP mirror, and
> i've mirrored it on the drive. now, i can mount it, and i can cd thru the
> directories, but when i do dselect, it can't find the s/w, and i get errors.
> i've configured the mtab, fstab, and apt things, and i still can't dselect.
> i'm NOT on a network, and i've managed to install a few things thru dpkg,
> accessing that HFS partitioned drive, including some pppoe s/w needed to
> access the net thru this comp. but as u know, thru dpkg, it's a long
> process, and i'm a newbie (on my 3rd day :-)), and i have to keep track of
> the dependencies, conflicts, and so on by hand. which is confusing the hell
> out of me.

apt-get is what dselect uses under the covers; dselect really just
provides a UI. So, you can do your tests with commands like 

apt-get install pppoe

and it will also get everthing needed to satisfy dependencies.  
> ok, what i did (thru apt-setup - which btw, isn't being found anymore. (???)
> i think it got deleted, but i haven't done any deletions of files. i don't
> know how to yet) was this:

Most likely, you tried to invoke apt-setup as a non-root user. Since
only root can modify /etc/apt/sources.list, it only makes sense to run
apt-setup as root, and it's found in an sbin directory (sbin's are not
on non-root user's PATHs).
> in /etc/apt/sources.list,  i have : deb file:/mnt/debian
>     and i've tried various things like file:/mnt, file:/debian,
> file:/mnt/whatever. u get the idea.

Although I haven't tried this, I suspect for a proper URL you need a
couple more slashes: file:///mnt/whatever.

> in blank fstab i have : /dev/sdb6 hfs 0 0
Might help to put 'defaults' as options here

*------v--------- Installing Debian GNU/Linux 3.0 --------v------*
|      <http://www.debian.org/releases/woody/installmanual>      |
|   debian-imac (potato): <http://debian-imac.sourceforge.net>   |
|            Chris Tillman        tillman@azstarnet.com          |
|                   May the Source be with you                   |

Reply to: