[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

x keyboard issue

hi all,

i'm using unstable quite a while and upgraded recently from a old
snapshot (maybe october this year) to an actual level. since then my
alt_r key does't work under x. so i start using google and found quite
a few solutions for this problem and tried these.

no one worked for my: the best think i get was somethink like that:

jules@serpent (~) % xmodmap                
xmodmap:  up to 2 keys per modifier, (keycodes in parentheses):

shift       Shift_L (0x32),  Shift_R (0x3e)
lock        Caps_Lock (0x42)
control     Control_L (0x25),  Control_R (0x6d)
mod1        Meta_L (0x71),  Meta_L (0x73)
mod3        Meta_L (0x71),  Meta_L (0x73)

this produces the following line when pressing the apple key in
conjunction with the first five letters from my qwertz keyboard:

  ?????? (f1 f7 e5 f2 f4 fa)

and I didn't get a working alt_r for accessing the pipe symbol, the at
and the keys {,},~. 

I'm in front of a apple powerbook g3 (pismo) with a german keyboard and
the last line has the following key order; the keycodes are embraced in

Fn    ctrl    alt    apple    space    keypad_enter   alt    cursor_block
       37      64      115      65      108           64

maybe someone can help me to mapping my alt_r key to keypad_enter or
the apple key. 

sorry if this was discussed in the archives. i've checked them but no
solution works for me. if this was answered in a mail, just give me
please the message-id so that i can find it.

thanks a lot ;)
"The cypherpunks credo is 'privacy through technology, not legislation.' 
The law of the land can be changed by the next administration. The Laws 
of mathematics are more rigid." -- Express, March 14, 1997, Cover Story

Reply to: