[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Beige G3 and USB Mouse

On 12/15/01 5:51 AM, "Chris Tillman" <toff@azstarnet.com> wrote:

> No, stick with bootX.

Thanks, I'd be happy to!

> The X server handles the mouse (and infact all hardware) independently
> of the way the console handles it. gpm is intended to make the mouse
> available in console mode, but only a few console applications can
> grok it. What results are you expecting?

I am expecting the mouse to work in console mode. Links understands it, mc
understands it, and you can even copy and paste on the console. I'd like to
have this functionality. Plus, if I can get it to work with gpm, that will
tell me what I need to know to make it to work with X.

Are there any specific kernel modules I should be looking for? Is that even
relevant? I would imagine the kernel distributed with the Debian-iMac
package would have USB activated, since the iMac has no ADB...

However, /proc/bus/usb is empty, making it seem like I should be looking
quite _lower_ than gpm. Although from what I've learned, if that directory
exists, then the kernel has USB compiled in, so hopefully I don't have to
learn how to recompile my kernel yet (though I intend to once I have a
satisfactory Debian system)

...a bit later and a tad more educated...

OK, I mounted usbdevfs, which seemed to make sense as to why USB wasn't
working, but other than putting the expected stuff in my /proc/bus/usb
directory (a 001 directory, and a device and driver file), it made no
difference. Before and after mounting usbdevfs, (which may already have been
mounted, although I didn't check my fstab or df -a), I get the following
message upon plugging in any USB device:

usb.c: USB new device connect assigned device number 2
usb_control/bulk_msg: timeout
usb_ohci.c: unlink URB timeout!
usb.c: USB device not accepting new address (error=-110)
usc.c: USB new device connect, assigned number -1
usb.c: USB new device not accepting new address (error=-12)
usb.c: USB disconnect on device -1

The message is the same regardless of the device. Devices tried:
IntelliMouse Explorer, Microtek Scanmaker X6, a self-powered hub, and a
Keyspan PDA adapter. The first line appears instantly, the rest appear about
a second later.

> In other words, if you really are interested in using the mouse in X
> applications, there's no need to muck around with gpm. In the most
> recent revision changelog to the X packages, Branden says
> (paraphrasing) if you insist on using gpm, you're on your own getting
> the mouse to work in X. That's because gpm imterrupts X's access to
> the hardware (as understand it).

I thought that this was only an issue with pre-4.x versions of XFree86, and
that 4.x could actually be pointed at /dev/gpmdata. However if that is not
the case, I have no problem turning gpm off before I start X.
> For X, you need to set the mouse configuration to
> /dev/input/mice. Don't add any nodes, etc. But definitely get the
> latest version of X, like 4.1.0 something, it has much better support
> of X for powerpc.

I will after I have a functional mouse :)

(Until that point I have no interest in any sort of gui)

> There are reams of information available on how to configure X, and
> particular mice. Have you checked /usr/share/doc/HOWTO/en-txt and
> .../HOWTO/en-txt/mini? How about /usr/share/doc/xserver-xfree86?

I checked the HOWTO's and mini-HOWTO's before posting to the list, and found
only one article relevant to mouse setup. However, this was for 3 button
serial mice, and had nothing to do with USB. I have also searched Google and
usenet (via Google) and although I found several instances similar (or
exactly the same) as my case, none of them seemed to ever be solved with the
successful results published. (I assume they either gave up or the knowledge
is so arcane they feel mere mortals are better off figuring it out

Finally, I checked linux-usb.org, and the only suggested solution there was
that I didn't have the hotplug scripts installed. Indeed I did not. I
installed them, started them up with a "/etc/init.d/hotplug start", and
everything still acted as it always had. It clearly sees the mouse, but
doesn't know what to do with it or how to talk to it right.

Granted, I still haven't tried everything I know how to do yet, but it is
just a _mouse_ yet the configuration possibilities seem _endless_. As much
as I detest the speed of OS X, I have to hand it to Apple now for supporting
USB on a machine that didn't originally have USB.

Please help! ;)


Reply to: