[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: XFree German Keymap on Pismo ... @ and | not working

Michel Dänzer <daenzer@debian.org> writes:

> On Mon, 2001-12-10 at 13:15, Michael Flaig wrote:
> > I've upgraded my Debian sid this morning and decided to switch to new
> > input layer. console works fine with "Apple USB".
> > 
> > but XFree doesn't work. I set in XF86Config-4:
> > 
> > Identifier      "Generic Keyboard"
> > Driver          "keyboard"
> > Option          "CoreKeyboard"
> > Option          "XkbRules"      "xfree86"
> > Option          "XkbModel"      "macintosh"
> > Option          "XkbLayout"     "de"
> > Option          "XkbVariant"    "nodeadkeys"
> > 
> > Has someone an idea what I set wrong?
> That's more or less the recommended configuration.
> > Where could be a problem?
> It's a known problem, but nobody wants to fix it... some keyboards don't
> generate the keycode that Xkb maps to AltGr.


I guess the above applies to an external keyboard. Is the keyboard on
Pismo working with Xkb enabled? I had to put XkbDisable in the config
file otherwise it is completely unusable - for example qwe is mapped
to -=BackSpace 

I have the new input layer and

Section "InputDevice"
        Identifier      "Generic Keyboard"
        Driver          "keyboard"
        Option          "CoreKeyboard"
        Option          "XkbRules"      "xfree86"
        Option          "XkbModel"      "macintosh"
        Option          "XkbLayout"     "us"

I'd like to switch to a Czech keyboard layout occasionally but no
success so far even with the dexconf default setting.

Reply to: