[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: XFree German Keymap on Pismo ... @ and | not working



On Mon, Dec 10, 2001 at 07:07:20PM +0100, Michel Dänzer wrote:
> On Mon, 2001-12-10 at 13:15, Michael Flaig wrote:
> 
> > I've upgraded my Debian sid this morning and decided to switch to new
> > input layer. console works fine with "Apple USB".
> > 
> > but XFree doesn't work. I set in XF86Config-4:
> > 
> > Identifier      "Generic Keyboard"
> > Driver          "keyboard"
> > Option          "CoreKeyboard"
> > Option          "XkbRules"      "xfree86"
> > Option          "XkbModel"      "macintosh"
> > Option          "XkbLayout"     "de"
> > Option          "XkbVariant"    "nodeadkeys"
> > 
> > Has someone an idea what I set wrong?
> 
> That's more or less the recommended configuration.
> 
> > Where could be a problem?
> 
> It's a known problem, but nobody wants to fix it... some keyboards don't
> generate the keycode that Xkb maps to AltGr.

If someone with such a keyboard would send me patches that are known to
work, I'd be happy to apply them.

The two files I'd look at are:

/etc/X11/xkb/keycodes/macintosh

and

/etc/X11/xkb/symbols/de

-- 
G. Branden Robinson                |    Damnit, we're all going to die;
Debian GNU/Linux                   |    let's die doing something *useful*!
branden@debian.org                 |    -- Hal Clement, on comments that
http://people.debian.org/~branden/ |       space exploration is dangerous

Attachment: pgplliDRUEpEZ.pgp
Description: PGP signature


Reply to: