[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Yet another question on yaboot/ybin


I have finally bought a CD-RW for my pismo, and my first project is to burn a 
custom, bootable rescue CD. 

I figured I would need to use initrd, but the documentation for initrd-tools 
is rather light, so I haven't figured out how to make use of initrd. After 
many mistakes (I made good use of the sample rewritable CD I received with 
the CD-RW), I have succeeded in burning a working root image that uses tmpfs 
instead of initrd. I can boot the CD using yaboot and kernel on my HD.

But my project is not finished,, as my final goal is to have a self-contained 
CD. The intermediate goal is to use yaboot on the HD, but use kernel from the 

Here's the transcript when I tried to boot:

boot:cd:,/vmlinux root=/dev/hde
Please wait, loading kernel...
ISO9660 disk
/vmlinux: Not a valid ELF image

boot:cd:,vmlinux root=/dev/hde
Please wait, loading kernel...
ISO9660 disk

Can't read Elf e_ident/e_type/e_machine info

FYI, /vmlinux is not a symlink, but the actual kernel image. I have also 
tried VMLINUX, /VMLINUX and cd:1, also tried burning a hybrid cd but no 
combination of those has worked so far.

Can you give me some pointers? Thanks!

Joongul Lee

PS. I don't subscribe to this list, so cc:me would be much appreciated.

Reply to: