[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Advice on a iBook ...



Carlos -

I just did my install on a TiBook the other day :) Unfortunately, the upgrade to unstable has been a rough road but things are looking good now. Got to get this keymap stuff taken care of ......

Not sure if I'm understanding your message right, but "default=" in yaboot.conf is referring to a kernel image label. It's the default choice when you just hit enter after getting the boot prompt.

> default=Linux

corresponds with

> image=/vmlinux
>      label=Linux
>      root=/dev/hda10
>      append="video=atyfb:mode:800x600-8"
>      read-only
>      partition=10


This way, you can add other kernel images and change the *default* kernel chosen when you boot Linux. I haven't tried this, but I bet you could change the default OS (between MacOS and Linux) on system boot by playing with the StartUp Disk control panel/preference thingy in MacOS. BTW - I don't think my config has a "macos=/dev/hdaXX" line.

-- Blake



CaRLoS mOGUeL wrote:

Based on ...

http://www.alaska.net/~erbenson/doc/mac-fdisk-basics.txt

Now my partition table is ...

/dev/hda1 ... /dev/hda2 ...
/dev/hda3 ...
/dev/hda4 ...
/dev/hda5 ...
/dev/hda6 ...
/dev/hda7 ...
/dev/hda8  APPLE_Bootstrap bootstrap (800.0K)
/dev/hda9  APPLE_UNIX_SVR2 swap      (100.0M)
/dev/hda10 APPLE_UNIX_SVR2 /         (1001.3M)
/dev/hda11 Apple_HFS       untitled2 (2.0G) // MacOS
/dev/hda7 ...

I installed first the MacOS side an then Debian 2.2r0,
before restarting the Debian installation a opened a
shell a edited the yaboot.conf file like this ...

default=Linux
boot=/dev/hda8
macos=/dev/hda11
device=hd:
delay=20
timeout=20
install=/target/boot/yaboot
magicboot=/target/etc/ofboot.b

/* After the firts reboot I changed the path to
/boot/yaboot and /etc/ofboot.b without the /target */

image=/vmlinux
     label=Linux
     root=/dev/hda10
     append="video=atyfb:mode:800x600-8"
     read-only
     partition=10

An use mkofboot -v -C /target/etc/yaboot.conf with no
errors. Now I boot straight to the Linux side and if I
keep the option key pushed it loads the graphical
loader between MacOS and Debian, I tried to change the
default OS to MacOS and choose Debian using the option
key ... I changed the "default" line to "macos" and
"/dev/hda11" in the yaboot.conf with no success ...
any other way ? (I run ybin after every modification
in the yaboot.conf file).

As a note ... everytime I boot into linux it said
hd:8,\\:tbxi loading Kernel ... not a valid ELF image.

Thanks in advanced ... now I feel that I'm walking to
the right way ( baby steps !!!).

Blessings ... Carlos.
--- Ethan Benson <erbenson@alaska.net> wrote:

On Thu, Oct 11, 2001 at 09:03:41AM -0700, CaRLoS
mOGUeL wrote:

to Debian. Since that everytime I reboot or start

the

iBook it sends me to the Open Firmware and nothing

you must have an 800K type Apple_Bootstrap partition
appearing before
all MacOS partitions, once that is there run
/usr/sbin/yabootconfig

--
Ethan Benson
http://www.alaska.net/~erbenson/



ATTACHMENT part 2 application/pgp-signature



__________________________________________________
Do You Yahoo!?
Make a great connection at Yahoo! Personals.
http://personals.yahoo.com







Reply to: