[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: kernel-image-2.4.8-powerpc

On Mon, Sep 17, 2001 at 05:01:36AM -0400, Adam C Powell IV wrote:
> Greetings,
> I finally had the time to give a good look at this pre-built 
> kernel-image (I know, took me long enough :-), and got it working, but 
> with a couple of problems along the way.
> Hardware: Motorola StarMax 3000/160 (pmac 4400 clone, 160 MHz 603e), 
> built-in Mach64 VT 1MB, PCI MacPicasso 540 (Cirrus Logic GD5480 chipset, 
> 4 MB).
>    * Using BootX, it always boots with the console on the Mach64,
>      unless I check the "No video driver" box.  (Didn't have a VGA
>      monitor to see what was wrong until this morning, the MacPicasso
>      has that funny Apple monitor port.)  This behavior is different
>      from 2.2.19, but I'm not sure whether it should be considered a
>      problem...

Probably not a real problem; you can force the load order on the
command line, though I don't remember how.

>    * When I check "No video driver", most of it is fine, but there are
>      color blocks with little circles in them between "VFS: diskquotas
>      version..." and "Console: switching to colour frame buffer...",
>      which look like what I used to get with CONFIG_VGA_CONSOLE=y, as
>      this kernel has.  But this is merely a cosmetic problem AFAICT.

This might be fixed now.  Uploading tonight.

>    * The machine hangs when trying to set the clock.  I notice there
>      are two rtc.o modules, in drivers/char and drivers/macintosh.
>       Could the kernel be trying to load the wrong one?  Worked around
>      this by setting HWCLOCKACCESS=no in /etc/default/rcS, but then I
>      have to rdate...

Fixed, by only including the right one.  I'm reasonably sure that I'm
ok with just the drivers/macintosh/rtc.o, unintuitively, on all
PowerPCs.  Someone smack me if I'm wrong.

>    * The machine hangs while "Starting printer spooler:".  Could it be
>      trying to insmod parport.o?  Worked around by purging lprng.

I can load parport without a crash now.

> So now I'm up and running with 2.4.8, but the 3nd and 4th problems above 
> should probably be worked on.
> Oh- and the openafs module builds and works!  Would anyone like me to 
> upload it?

Neeet.  I'll probably rebuild it against 2.4.12 sometime soon, if I
can.  I'd like to have AFS going again.

Daniel Jacobowitz                           Carnegie Mellon University
MontaVista Software                         Debian GNU/Linux Developer

Reply to: