[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: strange kernels behavior



Le Wed, 5 Sep 2001 15:56:30 -0800
Ethan Benson <erbenson@alaska.net> a ecrit:

> On Wed, Sep 05, 2001 at 07:44:40PM +0200, Damien GUIHAL wrote:
> > I've installed both lastest 2-2-19 and 2-4-8 kernels from testing and I have some problems using both of them :
> > 
> > while precedent release of 2-2-19 kernel worked really fine for me, lastest doesn't seem to care about my keymaps. I event tried to manually use loadkeys to load my keymap and other keymaps, which as no effect, the problem happen in console and with X. Meanwhile I have a strange bug wich give me some errors if I want to log into the console, and telnet is not accessible (allowing connections but leaving before asking a login).
> 
> install the latest console-data.  
> 
> > here is the message log. 
> > 
> > end_request: I/O error, dev 03:4b (hdb), sector 1067704
> > hdb: timeout waiting for DMA
> > hdb: irq timeout: status=0x51 { DriveReady SeekComplete Error }
> > hdb: irq timeout: error=0x40 { UncorrectableError }, LBAsect=7220218, sector=106770
> > 
> > hdb is my linux hdd while hda is my macos hdd
> 
> ewwww  either your using BootX on a newworld or your hardware is going bad.

I'm using yaboot, and macos (actually macosX) doesn't seems to complain about hardware, perhaps my hdb disk is getting tired....
 
> > Meanwhile with the 2-4-8 kernel, I have no keymap problems but I experienced some system freeze while accessing some files. I experienced the same problem for 2-2-19 kernel as for console login, excepted that it's not an error message I have but a system freeze. moreover when the kernel starts it produce a 4 strange lines filled with color rectangles including a circle, I'm pretty sure that it's not a kernel hacker's joke (but why not :-) ), and get an error message with the rtc module :
> > 
> > rtc: I/O port 112 is not free. 
> 
> you configured it wrong.  you must have CONFIG_RTC=n and CONFIG_PPC_RTC=y

I just get the kernel image package from debian testing so the error must be here I think.

> > I must add that I use a mixed testing/unstable system without any broken dependencies, on a black&white 400MHz G4. I want to mention either that I have no problem to log with kdm (except the fact that with the 2-2-19 kernel, as the keymap is completely false, it's not easy to type a correct password :-( )
> 
> install the newwest console-data.  it will install the correct keymap
> for linux keycodes.

I have the newest console-data (as for yesterday at least), and it didn't corrected the problem, and event if it's false, why loadkeys didn't have any effect.

Attachment: pgpF2Viq99qR4.pgp
Description: PGP signature


Reply to: