[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: yaboot/openfirmware question [again]

On Wed, Aug 15, 2001 at 12:46:34AM +0200, pejvan wrote:
> On 23/07/01 12:46, "Han The Thanh" <thanh@informatics.muni.cz> wrote:
> > Hi all,
> > 
> > I have installed yaboot with macOS, OSX and debian onto a powerbook. It
> > worked very well. Then when I tried to change starup disk in OSX, then the
> > yaboot menu doesn't show up at booting; the machine immediately boots up to
> > OSX. Booting to debian (using OF and the magic string boot hd:2,yaboot) and
> > rerun ybin didn't help. How can I fix this problem?
> > 
> I have the same problem, and i cannot solve it. Here is all i've tried :
> Since i've installed mac os x, my G4 is unable to boot by itself : at the
> boot i get weird picture : a torn system folder, and the boot process stops.
> I have to hold down 'halt' in order to be able to boot OS9 or 0SX
> But i simply cannot boot to linux anymore. I've tried everything :
> setenv boot-device hd:X,\\tbxi

wrong, let ybin do it.

> setenv boot-device hd:X,\\yaboot

also wrong.

> Where i've made X move from 0 to 10 (i have only 9 partitions on this
> drive...)
> Anyway, I always get the damn same error in OF : "can't OPEN: hd:X,\\tbxi"
> If i choose mac-boot, i get the torn system folder again
> Plus, i've zapped the pram (halt command P R) and typed in OF
> 'set-defaults', but nothing new happens.

it sounds like you didn't create your bootstrap partition correctly,
please send me the output of mac-fdisk -l /dev/hda, also show me your
/etc/yaboot.conf and dpkg -s yaboot | grep ^Version

Ethan Benson

Attachment: pgpS1JENrk4no.pgp
Description: PGP signature

Reply to: