[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: *mostly solved* Re: X4.0.3 and (german) keyboard problems on PM7600/132

Manuel Reiter wrote:

> > - I have X 4.0.3 up and running on the onboard video hardware (2MB of
> >   video RAM) using the framebuffer device. However, everything has a
> >   magenta hue, regardless of resolution. I include XF86Config-4 and
> >   xdm.log and would be grateful for any help.
> X seems to be fine in 24 and 15 bpp. I thought I'd tried that before, but
> X seems to ignore the -bpp option on startup and only adjusts the color
> depth if it's in the XF86Config file.

Try -depth instead. Depth 15 is also 16 bpp in X terminology.

> I'd still be interested to know why 16 bpp doesn't work, but 15 bpp at
> 1152x864 is fine for me.

Depth 16 is broken because the framebuffer device is broken.

> > - My german Apple Extended ADB keyboard is working on console and in X.
> >   However, the keys '<' and '^' seem to be swapped and, more importantly,
> >   I have no way to type an '@' or the pipe character ('|'). I can't even
> >   begin to tell you how handicapped I feel on the console without my
> >   trusty pipe ;) Any help would be greatly appreciated.
> I have solved the keyswaps following Stefan's suggestions but have still
> no luck with the 'pipe' and 'at' characters in X.

The best solution would probably be to switch to Linux keycodes and use
XkbModel "macintosh" (may only work with XFree86 4.1.0).

> > - While my one-button ADB mouse is working in X, three-button emulation is
> >   either not or I haven't figured it out. I tried the obvious approaches
> >   (all of Ctrl, Alt, Cmd, the F-keys) but to na avail. Again, thanks in
> >   advance for any light shed on this.
> I have fixed these, again thanks to Stefan, by putting
>   echo "1" > /proc/sys/dev/mac_hid/mouse_button_emulation
>   echo 100 > /proc/sys/dev/mac_hid/mouse_button2_keycode
>   echo 97 > /proc/sys/dev/mac_hid/mouse_button3_keycode
> into /etc/init.d/gpm , and now have the middle button on 'alt gr' and the
> right button on the right 'ctrl' key.

/etc/init.d/gpm isn't the best place for this, see sysctl.conf(5).

Earthling Michel Dänzer (MrCooper)    \   Debian GNU/Linux (powerpc) developer
CS student, Free Software enthusiast   \        XFree86 and DRI project member

Reply to: