[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Realtek 8029 not recognized

Francesco Brasini wrote:


I'm trying to bring new life to some old powermac 4400/200 here in the
Dept. of Mathematics of the University of Bologna, Italy, installing
Debian on them. Almost a success, but.... I'm still not able to see the
ethernet card.

"cat  /proc/pci" outputs:

 Bus  0, device  14, function  0:
   Ethernet controller: Realtek 8029 (rev 0).
     Medium devsel.  IRQ 24.
     I/O at 0x400 [0x401].

So I have searched the web for the correct driver and found ne2k-pci,
then I have recompiled the kernel (2.2.18pre21) with the following

but the card is still not recognized.

Any clue?

Nice job finding the right driver. :-)

Not 100% certain, but I think kernel-image-2.2.19-pmac (not sure it's in stable) has it as a module. (I have the 8029 NIC too.) So if it's not in stable, just use lynx or something to get the .deb and dpkg to install, then use modconf to add ne2k-pci to the auto-installed-at-boot list.

-Adam P.

GPG fingerprint: D54D 1AEE B11C CE9B A02B  C5DD 526F 01E8 564E E4B6

Welcome to the best software in the world today cafe! <http://lyre.mit.edu/%7Epowell/The_Best_Stuff_In_The_World_Today_Cafe.ogg>

Reply to: