[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: OF setting for Quik booting in a 7200

Gee, quik works just fine on my 7200.  But the OF is so lame that it doesn't really matter whether quik works or not.  The two reliable methods I use for the 7200 are a boot floppy (the one from the CD with the editing changes suggested by another lister to boot using my hard drive's root partition) or using BootX from MacOS, which very easily allows me to use several different kernels.  The later was harder this time around because I had to install macos from scratch, and all I have is this 7.5.2 CD, and you don't get much when install that!  Definitely no stuffit expander or any of that.  I eventually figured out how to download Expander_Installer_5.5.bin format and used hfsutils `unbin' command to get it ready to run.  Also, I did this using netatalk.  Don't ask how I ended up with that, but it worked.  I tried lots of other approaches first, booting back and forth between macos and linux, but that didn't seem to work.  Macos just didn't like the resulting files.


Use their FTP site for hassle free downloading.  Netscape wanted to slaughter the download file otherwise no matter what I did.

One weird thing is that booting with quik on the 7500/7600 was always hit or miss, 90% miss actually, because the lame OF just didn't understand that the drive takes time to get ready.  Even the various workarounds suggested on the nvsetenv man page and on this list didn't work.  So I made a special boot floppy as mentioned above.  Now quik works every time!  Just having the floppy in there for some reason makes it work.  The floppy drive isn't even in the boot path because boot-device is set to the scsi disk as per how you are supposed to get quik to work.  Amazing!


Mike Fedyk wrote:
> Ethan Benson wrote:
> >
> > On Tue, Feb 06, 2001 at 02:10:03PM -0800, Mike Fedyk wrote:
> > >
> > > I've spent the last month trying to get QUIK to work on a 7200, if you want to
> > > get it working in a reasonable time, make a 50MB hfs partition install MacOS 8.5
> > > and bootX.  It'll make the easiest boot loader I've ever worked with, 'cept for
> > > lilo.
> >
> > what kernel? the only problems a friend of mine has had is 2.2.15 and
> > 2.2.16 14 and 17 work great with quik.  you need to compile with
> > CONFIG_BOOTX=n though. (perhaps not on 2.2.18, im (rather he is) not
> > going to test it though)
> >
> All attempts have been made on a stock debian ppc kernel, which I have recently
> found has CONFIG_BOOTX_TEXT=y :(
> I'll give it another try next in the week after next, and try setting the
> boot-device using the SCSI ID.
> ... Hmm, on one of my 7200s /dev/sda is on mesh id 0
> Oh, well.  I'll compile a 2.2.18 or 19pre2 and test it with quik.
> Mike
> --
> To UNSUBSCRIBE, email to debian-powerpc-request@lists.debian.org
> with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: