[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

wierd Xpmac problem

in X, only my left shift key and left control key work
properly.  The ones on the right-hand side of the keyboard
are unresponsive.  Here's the details:

i've been using xpmac as my xserver happily for quite a
while now on my g4, and have been tracking woody since
the stable/testing/unstable split happened.  a couple 
of days ago i made an aborted attempt to try the new xfree
v4 packages.  one package had a problem (snapshot below)

| Unpacking xserver-xfree86 (from .../xserver-xfree86_4.0.2-1_powerpc.deb) ...
| Setting up xserver-xfree86 (4.0.2-1) ...
| Configuring Xserver-xfree86
| --------------------------
| sh: -c: line 1: unexpected EOF while looking for matching `''
| sh: -c: line 2: syntax error: unexpected end of file
|   a. ati    f. fbdev  m. mga      b. sis      v. vga
|   c. chips  g. glint  s. s3virge  t. trident
| Select the desired X server driver. 

i selected ati, and had a kernel panic when it tried to
do a modprobe.

So i decided i was in over my head.  Fortunately, all i had
to do to go back was remake the /etc/X11/X link back to
Xpmac and put my '-mode 19 -depth 16' arguments in a config
file...startx worked beautifully.

But, as i said at the beginning, i can only shift or control
with my left pinky -- a sad state of affairs for an emacs 

does anybody have any insights?  Since Xpmac doesns't have
the usual XF86Config file, i'm at a loss for altering the

i'm using rev10 of the Xpmac server...is there a more recent
one i could try?


Reply to: