[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Pismo Trackpad woes


I've just installed Debian Potato (grabbed the ISO images from linuxiso.org)
on my 2000 Powerbook Pismo and so far everything is great except:

I installed X windows and the Afterstep WM and can't get the trackpad to do
anything. I get an Afterstep login screen and the mouse pointer in the dead
center of the screen but can't move it an inch.

I've tried playing with the /etc/X11/XF86Config file and have managed to get
X to die during launch (which is not much of an improvement ;-)

So a couple of questions:

How do I stop X from launching at boot time - I tried removing it from my
/etc/inittab file but it wasn't there to remove...

And how do I get the pismo trackpad to work? Here's a snippet from my

    Section "Pointer"
        Protocol "IMPS/2"
        Device "/dev/usbmouse"
        /* blah blah blah */

And here's how startx responds to that:

(after all the usual x related messages)

    Fatal server error:
    Cannot open mouse (No such device)

If I try to 'cat /dev/usbmouse' I get:

    cat: /dev/usbmouse: No such device

But I know full well /dev/usbmouse is there:

    ls -la /dev/usbmouse

    crw-rw---- 1 root root 10, 32 Nov 22 12:03 /dev/usbmouse

Which makes me wonder that the trackpad isn't a usbmouse at all... (although
if I plug a usbmouse in the back of the laptop I still get the same errors -
so much for deductive reasoning)

Can anyone tell me what I should be doing???

And one final quick question - anyone got debian working on a Titanium
Powerbook yet?


Reply to: