[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

LS-120 drive

Hi, I'm running 2.2r2, kernel 2.2.1pre20-ben3 and I'm trying to get my imation
LS-120 superdrive to work (on my revA imac)

I've applied the patch to usb-storage.c and compiled and inserted it, but I
seem to be having trouble with scsi emulation still.  When I try 'mount -t
vfat /dev/sda /mnt' I get:
mount: the kernel does not recognise /dev/sda as a block device
       (maybe `insmod driver'?)
and 'mount -t vfat /dev/sg0 /mnt' (with or without module sg inserted):
mount: /dev/sg0 is not a block device

These are the messages from dmesg after 'insmod usb-storage' (with drive 
already connected):
usb.c: registered new driver usb-storage
scsi1 : SCSI emulation for USB Mass Storage devices
scsi : 2 hosts.
usb-storage: bus_reset() requested but not implemented
usb-storage: bus_reset() requested but not implemented
usb-storage: host_reset() requested but not implemented
WARNING: USB Mass Storage data integrity not assured
USB Mass Storage device found at 5
USB Mass Storage support registered.

The entry for the drive from /proc/bus/usb/devices is:
T:  Bus=01 Lev=02 Prnt=02 Port=02 Cnt=03 Dev#=  5 Spd=12  MxCh= 0
D:  Ver= 1.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=04e6 ProdID=0001 Rev= 2.00
S:  Manufacturer=Shuttle Technology Inc.
S:  Product=E-USB Bridge
C:* #Ifs= 1 Cfg#= 1 Atr=40 MxPwr=  0mA
I:  If#= 0 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=00 Prot=00 Driver=usb-storage
E:  Ad=01(O) Atr=02(Bulk) MxPS=  64 Ivl=  0ms
E:  Ad=82(I) Atr=02(Bulk) MxPS=  64 Ivl=  0ms
E:  Ad=83(I) Atr=03(Int.) MxPS=   2 Ivl=255ms

Does anyone have any ideas?  I would be happy to supply any further
information.  Thanks in advance, Mark.

Reply to: