[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: fdisk kernel panic

Bruce McIntyre wrote:

 I am continuing to have frustration with my internal hard disk (7300,
 Quantum Fireball 2.1) I decided to this time mash Apple OS
 altogether, and so gave mac-fdisk the 'i' command to write a new
 patition map. I was suspecting that the apple patch and driver 43
 patitions were causing the scsi error 80000000 that I was getting
 with my previous installs. The initialisation went fine (fdisk
 prompts you to enter the block size of the disk, which I got from
 first giving it the 'p' command---it returns a size 1 block less than
 that given by dmesg). I wrote in some partitions. 32M Root, 32M swap,
 100M var, 500M home and the rest usr. when I gave mac-fdisk the 'w'
 command (to write the new patition table) it freaked out and gave me
 something like (copied by hand from screen):
Kernel access of bad area pc c0206808 lr c0205a70 address 4 task mac-fdisk 44
 it then panicked and all consoles froze as it attempted reboot (which
 never eventuated).

 Now I cannot reinstall a working Mac system on the disk to start the
 debian tranistion--- it formats ok with the apple Drive Setup
 utillity, but refuses to make the disk bootable with the startup disk
 control panel (system writes to it ok in the install program).
 while the startup control panel indicates it is the boot disk, at
 boot i dont get anything, only grey... not even the disk icon.
 to boot again from cd, i have to erase the pram, and then reboot with
 c and d held down. after a minute or two of indecision it boots, and
 mounts the drive fine, with the system on it and still indicating
 that it is the boot disk.
 The drive is on the mesh bus at id 1. (I have been trying different
 ids to get debian without scsi errors to no avail)
 Is my computer cursed?

Probably not.

I have a 7300 and it's a good machine, but it's hard drive is starting to go bad
on one sector.  I'm going to have to get a new drive.  You might try that too.

Would love to but am starving musician! (I have checked out the sectors with 3 different progs: they _seem_ fine)

Here's some other things to try:

Remove and reinstall the memory modules and cpu board

the potential for me breaking it worse is huge here...

Unplug each connector and reinstall them; like the scsi cables, power cables,

Have done with scsi--- strange thing is that the drive is always found and usable when booting from cd.... I don't think it's a simple intermittent problem (contradiction in terms?!) perhaps open firmware is not looking on mace at id 1 for boot (is that id reserved for external bus or somthing wierd like that ? I'm going to put the drive back on 0 (time to get screwdriver) and i'll report on progress again.

Check the power output of the power supply with a voltage meter (buy a power
extender and cut and strip the cable to attach the meter clips)  Sorry, don't
know which wires to check...

Kicking it a couple times might help... ;)

didn't someone make a cushion in the shape of a mac plus for that purpose once :-)

Hope this helps,


Reply to: