[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: USB mouse in X

On Mon, 11 Dec 2000, Tim Hodgson wrote:

> I've just installed potato on a Mac 9500, and it's all (more or less) 
> OK except for the mouse. This is a Logitech USB mouse attached to an 
> Entrega PCI card. The combination worked fine under LinuxPPC and YDL, 
> btw. The puzzling part is that _occasionally_ the mouse will move for 
> a few seconds, then nothing. No response to clicks. I'd assume it was 
> a hardware problem except that it's fine under MacOS and was fine, as 
> i said, with other distros. I've tried all kinds of settings in 
> XF86Config; it's currently set to IMPS/2 protocol, with /dev/mouse 
> symlinked to /dev/usbmouse.

If you have gpm running, it may be interfering with the X server. Try
stopping gpm and then running X.

If this is the problem, you can solve it by telling gpm to repeat with
type "raw" (in /etc/gpm.conf) and making /dev/mouse a link to

Alternately, you can run a recent kernel with the new input layer. Then
your mouse device will be /dev/input/mice, and it will work with both gpm
and X at the same time.

Reply to: